summaryrefslogtreecommitdiffstats
path: root/third_party/rust/either
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/either')
-rw-r--r--third_party/rust/either/.cargo-checksum.json1
-rw-r--r--third_party/rust/either/Cargo.toml22
-rw-r--r--third_party/rust/either/LICENSE-APACHE201
-rw-r--r--third_party/rust/either/LICENSE-MIT25
-rw-r--r--third_party/rust/either/README.rst88
-rw-r--r--third_party/rust/either/src/lib.rs602
6 files changed, 939 insertions, 0 deletions
diff --git a/third_party/rust/either/.cargo-checksum.json b/third_party/rust/either/.cargo-checksum.json
new file mode 100644
index 0000000000..4164f37198
--- /dev/null
+++ b/third_party/rust/either/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"76b9389a7d769eff88be373c17bc7384f8a55e15aea2d8955fffb07cf51ca413","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"7576269ea71f767b99297934c0b2367532690f8c4badc695edf8e04ab6a1e545","README.rst":"3813c794770085af90f88860e71fb8f172472584a4844de6e4a4ad32be084589","src/lib.rs":"5179302c50ad3f20fb54ffaacbbfd2c58a0273f98ae753a3b8a6632f0e954b8a"},"package":"18785c1ba806c258137c937e44ada9ee7e69a37e3c72077542cd2f069d78562a"} \ No newline at end of file
diff --git a/third_party/rust/either/Cargo.toml b/third_party/rust/either/Cargo.toml
new file mode 100644
index 0000000000..1265ea333a
--- /dev/null
+++ b/third_party/rust/either/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "either"
+version = "1.1.0"
+authors = ["bluss"]
+
+license = "MIT/Apache-2.0"
+repository = "https://github.com/bluss/either"
+documentation = "https://docs.rs/either/1/"
+
+description = """
+The enum `Either`, with variants `Left` and `Right` and trait implementations including Iterator, Read, Write.
+
+Either has methods that are similar to Option and Result.
+
+Includes convenience macros `try_left!()` and `try_right!()` to use for short-circuiting logic."""
+
+keywords = ["data-structure", "no_std"]
+categories = ["data-structures", "no-std"]
+
+[features]
+default = ["use_std"]
+use_std = []
diff --git a/third_party/rust/either/LICENSE-APACHE b/third_party/rust/either/LICENSE-APACHE
new file mode 100644
index 0000000000..16fe87b06e
--- /dev/null
+++ b/third_party/rust/either/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/third_party/rust/either/LICENSE-MIT b/third_party/rust/either/LICENSE-MIT
new file mode 100644
index 0000000000..9203baa055
--- /dev/null
+++ b/third_party/rust/either/LICENSE-MIT
@@ -0,0 +1,25 @@
+Copyright (c) 2015
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/third_party/rust/either/README.rst b/third_party/rust/either/README.rst
new file mode 100644
index 0000000000..ddd17ea308
--- /dev/null
+++ b/third_party/rust/either/README.rst
@@ -0,0 +1,88 @@
+
+Either
+======
+
+The enum ``Either`` with variants ``Left`` and ``Right`` and trait
+implementations including Iterator, Read, Write.
+
+Either has methods that are similar to Option and Result.
+
+Includes convenience macros ``try_left!()`` and ``try_right!()`` to use for
+short-circuiting logic.
+
+Please read the `API documentation here`__
+
+__ https://docs.rs/either/
+
+|build_status|_ |crates|_
+
+.. |build_status| image:: https://travis-ci.org/bluss/either.svg?branch=master
+.. _build_status: https://travis-ci.org/bluss/either
+
+.. |crates| image:: http://meritbadge.herokuapp.com/either
+.. _crates: https://crates.io/crates/either
+
+How to use with cargo::
+
+ [dependencies]
+ either = "1.0"
+
+
+Recent Changes
+--------------
+
+- 1.1.0
+
+ - Add methods ``left_and_then``, ``right_and_then`` by @rampantmonkey
+ - Include license files in the repository and released crate
+
+- 1.0.3
+
+ - Add crate categories
+
+- 1.0.2
+
+ - Forward more ``Iterator`` methods
+ - Implement ``Extend`` for ``Either<L, R>`` if ``L, R`` do.
+
+- 1.0.1
+
+ - Fix ``Iterator`` impl for ``Either`` to forward ``.fold()``.
+
+- 1.0.0
+
+ - Add default crate feature ``use_std`` so that you can opt out of linking to
+ std.
+
+- 0.1.7
+
+ - Add methods ``.map_left()``, ``.map_right()`` and ``.either()``.
+ - Add more documentation
+
+- 0.1.3
+
+ - Implement Display, Error
+
+- 0.1.2
+
+ - Add macros ``try_left!`` and ``try_right!``.
+
+- 0.1.1
+
+ - Implement Deref, DerefMut
+
+- 0.1.0
+
+ - Initial release
+ - Support Iterator, Read, Write
+
+License
+-------
+
+Dual-licensed to be compatible with the Rust project.
+
+Licensed under the Apache License, Version 2.0
+http://www.apache.org/licenses/LICENSE-2.0 or the MIT license
+http://opensource.org/licenses/MIT, at your
+option. This file may not be copied, modified, or distributed
+except according to those terms.
diff --git a/third_party/rust/either/src/lib.rs b/third_party/rust/either/src/lib.rs
new file mode 100644
index 0000000000..a28340782f
--- /dev/null
+++ b/third_party/rust/either/src/lib.rs
@@ -0,0 +1,602 @@
+//! The enum [**Either**](enum.Either.html).
+//!
+//! **Crate features:**
+//!
+//! * `"use_std"`
+//! Enabled by default. Disable to make the library `#![no_std]`.
+//!
+
+#![doc(html_root_url = "https://docs.rs/either/1/")]
+#![cfg_attr(all(not(test), not(feature = "use_std")), no_std)]
+#[cfg(all(not(test), not(feature = "use_std")))]
+extern crate core as std;
+
+use std::convert::{AsRef, AsMut};
+use std::fmt;
+use std::iter;
+use std::ops::Deref;
+use std::ops::DerefMut;
+#[cfg(any(test, feature = "use_std"))]
+use std::io::{self, Write, Read, BufRead};
+#[cfg(any(test, feature = "use_std"))]
+use std::error::Error;
+
+pub use Either::{Left, Right};
+
+/// `Either` represents an alternative holding one value out of
+/// either of the two possible values.
+///
+/// `Either` is a general purpose sum type of two parts. For representing
+/// success or error, use the regular `Result<T, E>` instead.
+#[derive(Copy, Clone, PartialEq, Eq, PartialOrd, Ord, Hash, Debug)]
+pub enum Either<L, R> {
+ /// A value of type `L`.
+ Left(L),
+ /// A value of type `R`.
+ Right(R),
+}
+
+macro_rules! either {
+ ($value:expr, $pattern:pat => $result:expr) => (
+ match $value {
+ Either::Left($pattern) => $result,
+ Either::Right($pattern) => $result,
+ }
+ )
+}
+
+/// Macro for unwrapping the left side of an `Either`, which fails early
+/// with the opposite side. Can only be used in functions that return
+/// `Either` because of the early return of `Right` that it provides.
+///
+/// See also `try_right!` for its dual, which applies the same just to the
+/// right side.
+///
+/// # Example
+///
+/// ```
+/// #[macro_use] extern crate either;
+/// use either::{Either, Left, Right};
+///
+/// fn twice(wrapper: Either<u32, &str>) -> Either<u32, &str> {
+/// let value = try_left!(wrapper);
+/// Left(value * 2)
+/// }
+///
+/// fn main() {
+/// assert_eq!(twice(Left(2)), Left(4));
+/// assert_eq!(twice(Right("ups")), Right("ups"));
+/// }
+/// ```
+#[macro_export]
+macro_rules! try_left {
+ ($expr:expr) => (
+ match $expr {
+ $crate::Left(val) => val,
+ $crate::Right(err) => return $crate::Right(::std::convert::From::from(err))
+ }
+ )
+}
+
+/// Dual to `try_left!`, see its documentation for more information.
+#[macro_export]
+macro_rules! try_right {
+ ($expr:expr) => (
+ match $expr {
+ $crate::Left(err) => return $crate::Left(::std::convert::From::from(err)),
+ $crate::Right(val) => val
+ }
+ )
+}
+
+impl<L, R> Either<L, R> {
+ /// Return true if the value is the `Left` variant.
+ ///
+ /// ```
+ /// use either::*;
+ ///
+ /// let values = [Left(1), Right("the right value")];
+ /// assert_eq!(values[0].is_left(), true);
+ /// assert_eq!(values[1].is_left(), false);
+ /// ```
+ pub fn is_left(&self) -> bool {
+ match *self {
+ Left(_) => true,
+ Right(_) => false,
+ }
+ }
+
+ /// Return true if the value is the `Right` variant.
+ ///
+ /// ```
+ /// use either::*;
+ ///
+ /// let values = [Left(1), Right("the right value")];
+ /// assert_eq!(values[0].is_right(), false);
+ /// assert_eq!(values[1].is_right(), true);
+ /// ```
+ pub fn is_right(&self) -> bool {
+ !self.is_left()
+ }
+
+ /// Convert the left side of `Either<L, R>` to an `Option<L>`.
+ ///
+ /// ```
+ /// use either::*;
+ ///
+ /// let left: Either<_, ()> = Left("some value");
+ /// assert_eq!(left.left(), Some("some value"));
+ ///
+ /// let right: Either<(), _> = Right(321);
+ /// assert_eq!(right.left(), None);
+ /// ```
+ pub fn left(self) -> Option<L> {
+ match self {
+ Left(l) => Some(l),
+ Right(_) => None,
+ }
+ }
+
+ /// Convert the right side of `Either<L, R>` to an `Option<R>`.
+ ///
+ /// ```
+ /// use either::*;
+ ///
+ /// let left: Either<_, ()> = Left("some value");
+ /// assert_eq!(left.right(), None);
+ ///
+ /// let right: Either<(), _> = Right(321);
+ /// assert_eq!(right.right(), Some(321));
+ /// ```
+ pub fn right(self) -> Option<R> {
+ match self {
+ Left(_) => None,
+ Right(r) => Some(r),
+ }
+ }
+
+ /// Convert `&Either<L, R>` to `Either<&L, &R>`.
+ ///
+ /// ```
+ /// use either::*;
+ ///
+ /// let left: Either<_, ()> = Left("some value");
+ /// assert_eq!(left.as_ref(), Left(&"some value"));
+ ///
+ /// let right: Either<(), _> = Right("some value");
+ /// assert_eq!(right.as_ref(), Right(&"some value"));
+ /// ```
+ pub fn as_ref(&self) -> Either<&L, &R> {
+ match *self {
+ Left(ref inner) => Left(inner),
+ Right(ref inner) => Right(inner),
+ }
+ }
+
+ /// Convert `&mut Either<L, R>` to `Either<&mut L, &mut R>`.
+ ///
+ /// ```
+ /// use either::*;
+ ///
+ /// fn mutate_left(value: &mut Either<u32, u32>) {
+ /// if let Some(l) = value.as_mut().left() {
+ /// *l = 999;
+ /// }
+ /// }
+ ///
+ /// let mut left = Left(123);
+ /// let mut right = Right(123);
+ /// mutate_left(&mut left);
+ /// mutate_left(&mut right);
+ /// assert_eq!(left, Left(999));
+ /// assert_eq!(right, Right(123));
+ /// ```
+ pub fn as_mut(&mut self) -> Either<&mut L, &mut R> {
+ match *self {
+ Left(ref mut inner) => Left(inner),
+ Right(ref mut inner) => Right(inner),
+ }
+ }
+
+ /// Convert `Either<L, R>` to `Either<R, L>`.
+ ///
+ /// ```
+ /// use either::*;
+ ///
+ /// let left: Either<_, ()> = Left(123);
+ /// assert_eq!(left.flip(), Right(123));
+ ///
+ /// let right: Either<(), _> = Right("some value");
+ /// assert_eq!(right.flip(), Left("some value"));
+ /// ```
+ pub fn flip(self) -> Either<R, L> {
+ match self {
+ Left(l) => Right(l),
+ Right(r) => Left(r),
+ }
+ }
+
+ /// Apply the function `f` on the value in the `Left` variant if it is present rewrapping the
+ /// result in `Left`.
+ ///
+ /// ```
+ /// use either::*;
+ ///
+ /// let left: Either<_, u32> = Left(123);
+ /// assert_eq!(left.map_left(|x| x * 2), Left(246));
+ ///
+ /// let right: Either<u32, _> = Right(123);
+ /// assert_eq!(right.map_left(|x| x * 2), Right(123));
+ /// ```
+ pub fn map_left<F, M>(self, f: F) -> Either<M, R>
+ where F: FnOnce(L) -> M
+ {
+ match self {
+ Left(l) => Left(f(l)),
+ Right(r) => Right(r),
+ }
+ }
+
+ /// Apply the function `f` on the value in the `Right` variant if it is present rewrapping the
+ /// result in `Right`.
+ ///
+ /// ```
+ /// use either::*;
+ ///
+ /// let left: Either<_, u32> = Left(123);
+ /// assert_eq!(left.map_right(|x| x * 2), Left(123));
+ ///
+ /// let right: Either<u32, _> = Right(123);
+ /// assert_eq!(right.map_right(|x| x * 2), Right(246));
+ /// ```
+ pub fn map_right<F, S>(self, f: F) -> Either<L, S>
+ where F: FnOnce(R) -> S
+ {
+ match self {
+ Left(l) => Left(l),
+ Right(r) => Right(f(r)),
+ }
+ }
+
+ /// Apply one of two functions depending on contents, unifying their result. If the value is
+ /// `Left(L)` then the first function `f` is applied; if it is `Right(R)` then the second
+ /// function `g` is applied.
+ ///
+ /// ```
+ /// use either::*;
+ ///
+ /// fn square(n: u32) -> i32 { (n * n) as i32 }
+ /// fn negate(n: i32) -> i32 { -n }
+ ///
+ /// let left: Either<u32, i32> = Left(4);
+ /// assert_eq!(left.either(square, negate), 16);
+ ///
+ /// let right: Either<u32, i32> = Right(-4);
+ /// assert_eq!(right.either(square, negate), 4);
+ /// ```
+ pub fn either<F, G, T>(self, f: F, g: G) -> T
+ where F: FnOnce(L) -> T,
+ G: FnOnce(R) -> T
+ {
+ match self {
+ Left(l) => f(l),
+ Right(r) => g(r),
+ }
+ }
+
+ /// Apply the function `f` on the value in the `Left` variant if it is present.
+ ///
+ /// ```
+ /// use either::*;
+ ///
+ /// let left: Either<_, u32> = Left(123);
+ /// assert_eq!(left.left_and_then::<_,()>(|x| Right(x * 2)), Right(246));
+ ///
+ /// let right: Either<u32, _> = Right(123);
+ /// assert_eq!(right.left_and_then(|x| Right::<(), _>(x * 2)), Right(123));
+ /// ```
+ pub fn left_and_then<F, S>(self, f: F) -> Either<S, R>
+ where F: FnOnce(L) -> Either<S, R>
+ {
+ match self {
+ Left(l) => f(l),
+ Right(r) => Right(r),
+ }
+ }
+
+ /// Apply the function `f` on the value in the `Right` variant if it is present.
+ ///
+ /// ```
+ /// use either::*;
+ ///
+ /// let left: Either<_, u32> = Left(123);
+ /// assert_eq!(left.right_and_then(|x| Right(x * 2)), Left(123));
+ ///
+ /// let right: Either<u32, _> = Right(123);
+ /// assert_eq!(right.right_and_then(|x| Right(x * 2)), Right(246));
+ /// ```
+ pub fn right_and_then<F, S>(self, f: F) -> Either<L, S>
+ where F: FnOnce(R) -> Either<L, S>
+ {
+ match self {
+ Left(l) => Left(l),
+ Right(r) => f(r),
+ }
+ }
+}
+
+/// Convert from `Result` to `Either` with `Ok => Right` and `Err => Left`.
+impl<L, R> From<Result<R, L>> for Either<L, R> {
+ fn from(r: Result<R, L>) -> Self {
+ match r {
+ Err(e) => Left(e),
+ Ok(o) => Right(o),
+ }
+ }
+}
+
+/// Convert from `Either` to `Result` with `Right => Ok` and `Left => Err`.
+impl<L, R> Into<Result<R, L>> for Either<L, R> {
+ fn into(self) -> Result<R, L> {
+ match self {
+ Left(l) => Err(l),
+ Right(r) => Ok(r),
+ }
+ }
+}
+
+impl<L, R, A> Extend<A> for Either<L, R>
+ where L: Extend<A>, R: Extend<A>
+{
+ fn extend<T>(&mut self, iter: T)
+ where T: IntoIterator<Item=A>
+ {
+ either!(*self, ref mut inner => inner.extend(iter))
+ }
+}
+
+/// `Either<L, R>` is an iterator if both `L` and `R` are iterators.
+impl<L, R> Iterator for Either<L, R>
+ where L: Iterator, R: Iterator<Item=L::Item>
+{
+ type Item = L::Item;
+
+ fn next(&mut self) -> Option<Self::Item> {
+ either!(*self, ref mut inner => inner.next())
+ }
+
+ fn size_hint(&self) -> (usize, Option<usize>) {
+ either!(*self, ref inner => inner.size_hint())
+ }
+
+ fn fold<Acc, G>(self, init: Acc, f: G) -> Acc
+ where G: FnMut(Acc, Self::Item) -> Acc,
+ {
+ either!(self, inner => inner.fold(init, f))
+ }
+
+ fn count(self) -> usize {
+ either!(self, inner => inner.count())
+ }
+
+ fn last(self) -> Option<Self::Item> {
+ either!(self, inner => inner.last())
+ }
+
+ fn nth(&mut self, n: usize) -> Option<Self::Item> {
+ either!(*self, ref mut inner => inner.nth(n))
+ }
+
+ fn collect<B>(self) -> B
+ where B: iter::FromIterator<Self::Item>
+ {
+ either!(self, inner => inner.collect())
+ }
+
+ fn all<F>(&mut self, f: F) -> bool
+ where F: FnMut(Self::Item) -> bool
+ {
+ either!(*self, ref mut inner => inner.all(f))
+ }
+}
+
+impl<L, R> DoubleEndedIterator for Either<L, R>
+ where L: DoubleEndedIterator, R: DoubleEndedIterator<Item=L::Item>
+{
+ fn next_back(&mut self) -> Option<Self::Item> {
+ either!(*self, ref mut inner => inner.next_back())
+ }
+}
+
+impl<L, R> ExactSizeIterator for Either<L, R>
+ where L: ExactSizeIterator, R: ExactSizeIterator<Item=L::Item>
+{
+}
+
+#[cfg(any(test, feature = "use_std"))]
+/// `Either<L, R>` implements `Read` if both `L` and `R` do.
+///
+/// Requires crate feature `"use_std"`
+impl<L, R> Read for Either<L, R>
+ where L: Read, R: Read
+{
+ fn read(&mut self, buf: &mut [u8]) -> io::Result<usize> {
+ either!(*self, ref mut inner => inner.read(buf))
+ }
+
+ fn read_to_end(&mut self, buf: &mut Vec<u8>) -> io::Result<usize> {
+ either!(*self, ref mut inner => inner.read_to_end(buf))
+ }
+}
+
+#[cfg(any(test, feature = "use_std"))]
+/// Requires crate feature `"use_std"`
+impl<L, R> BufRead for Either<L, R>
+ where L: BufRead, R: BufRead
+{
+ fn fill_buf(&mut self) -> io::Result<&[u8]> {
+ either!(*self, ref mut inner => inner.fill_buf())
+ }
+
+ fn consume(&mut self, amt: usize) {
+ either!(*self, ref mut inner => inner.consume(amt))
+ }
+}
+
+#[cfg(any(test, feature = "use_std"))]
+/// `Either<L, R>` implements `Write` if both `L` and `R` do.
+///
+/// Requires crate feature `"use_std"`
+impl<L, R> Write for Either<L, R>
+ where L: Write, R: Write
+{
+ fn write(&mut self, buf: &[u8]) -> io::Result<usize> {
+ either!(*self, ref mut inner => inner.write(buf))
+ }
+
+ fn flush(&mut self) -> io::Result<()> {
+ either!(*self, ref mut inner => inner.flush())
+ }
+}
+
+impl<L, R, Target> AsRef<Target> for Either<L, R>
+ where L: AsRef<Target>, R: AsRef<Target>
+{
+ fn as_ref(&self) -> &Target {
+ either!(*self, ref inner => inner.as_ref())
+ }
+}
+
+impl<L, R, Target> AsMut<Target> for Either<L, R>
+ where L: AsMut<Target>, R: AsMut<Target>
+{
+ fn as_mut(&mut self) -> &mut Target {
+ either!(*self, ref mut inner => inner.as_mut())
+ }
+}
+
+impl<L, R> Deref for Either<L, R>
+ where L: Deref, R: Deref<Target=L::Target>
+{
+ type Target = L::Target;
+
+ fn deref(&self) -> &Self::Target {
+ either!(*self, ref inner => &*inner)
+ }
+}
+
+impl<L, R> DerefMut for Either<L, R>
+ where L: DerefMut, R: DerefMut<Target=L::Target>
+{
+ fn deref_mut(&mut self) -> &mut Self::Target {
+ either!(*self, ref mut inner => &mut *inner)
+ }
+}
+
+#[cfg(any(test, feature = "use_std"))]
+/// `Either` implements `Error` if *both* `L` and `R` implement it.
+impl<L, R> Error for Either<L, R>
+ where L: Error, R: Error
+{
+ fn description(&self) -> &str {
+ either!(*self, ref inner => inner.description())
+ }
+
+ fn cause(&self) -> Option<&Error> {
+ either!(*self, ref inner => inner.cause())
+ }
+}
+
+impl<L, R> fmt::Display for Either<L, R>
+ where L: fmt::Display, R: fmt::Display
+{
+ fn fmt(&self, f: &mut fmt::Formatter) -> fmt::Result {
+ either!(*self, ref inner => inner.fmt(f))
+ }
+}
+
+#[test]
+fn basic() {
+ let mut e = Left(2);
+ let r = Right(2);
+ assert_eq!(e, Left(2));
+ e = r;
+ assert_eq!(e, Right(2));
+ assert_eq!(e.left(), None);
+ assert_eq!(e.right(), Some(2));
+ assert_eq!(e.as_ref().right(), Some(&2));
+ assert_eq!(e.as_mut().right(), Some(&mut 2));
+}
+
+#[test]
+fn macros() {
+ fn a() -> Either<u32, u32> {
+ let x: u32 = try_left!(Right(1337u32));
+ Left(x * 2)
+ }
+ assert_eq!(a(), Right(1337));
+
+ fn b() -> Either<String, &'static str> {
+ Right(try_right!(Left("foo bar")))
+ }
+ assert_eq!(b(), Left(String::from("foo bar")));
+}
+
+#[test]
+fn deref() {
+ fn is_str(_: &str) {}
+ let value: Either<String, &str> = Left(String::from("test"));
+ is_str(&*value);
+}
+
+#[test]
+fn iter() {
+ let x = 3;
+ let mut iter = match x {
+ 1...3 => Left(0..10),
+ _ => Right(17..),
+ };
+
+ assert_eq!(iter.next(), Some(0));
+ assert_eq!(iter.count(), 9);
+}
+
+#[test]
+fn read_write() {
+ use std::io;
+
+ let use_stdio = false;
+ let mockdata = [0xff; 256];
+
+ let mut reader = if use_stdio {
+ Left(io::stdin())
+ } else {
+ Right(&mockdata[..])
+ };
+
+ let mut buf = [0u8; 16];
+ assert_eq!(reader.read(&mut buf).unwrap(), buf.len());
+ assert_eq!(&buf, &mockdata[..buf.len()]);
+
+ let mut mockbuf = [0u8; 256];
+ let mut writer = if use_stdio {
+ Left(io::stdout())
+ } else {
+ Right(&mut mockbuf[..])
+ };
+
+ let buf = [1u8; 16];
+ assert_eq!(writer.write(&buf).unwrap(), buf.len());
+}
+
+#[test]
+fn error() {
+ let invalid_utf8 = b"\xff";
+ let res = || -> Result<_, Either<_, _>> {
+ try!(::std::str::from_utf8(invalid_utf8).map_err(Left));
+ try!("x".parse::<i32>().map_err(Right));
+ Ok(())
+ }();
+ assert!(res.is_err());
+ res.unwrap_err().description(); // make sure this can be called
+}