summaryrefslogtreecommitdiffstats
path: root/third_party/rust/failure/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/failure/Cargo.toml')
-rw-r--r--third_party/rust/failure/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/third_party/rust/failure/Cargo.toml b/third_party/rust/failure/Cargo.toml
new file mode 100644
index 0000000000..8d6802028d
--- /dev/null
+++ b/third_party/rust/failure/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+authors = ["Without Boats <boats@mozilla.com>"]
+description = "Experimental error handling abstraction."
+documentation = "https://docs.rs/failure"
+homepage = "https://rust-lang-nursery.github.io/failure/"
+license = "MIT OR Apache-2.0"
+name = "failure"
+repository = "https://github.com/rust-lang-nursery/failure"
+version = "0.1.6"
+
+[dependencies.failure_derive]
+optional = true
+version = "0.1.6"
+path = "./failure_derive"
+
+[dependencies.backtrace]
+optional = true
+version = "0.3.3"
+
+[workspace]
+members = [".", "failure_derive"]
+
+[features]
+default = ["std", "derive"]
+#small-error = ["std"]
+std = []
+derive = ["failure_derive"]