summaryrefslogtreecommitdiffstats
path: root/third_party/rust/futures-util/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/futures-util/Cargo.toml')
-rw-r--r--third_party/rust/futures-util/Cargo.toml97
1 files changed, 97 insertions, 0 deletions
diff --git a/third_party/rust/futures-util/Cargo.toml b/third_party/rust/futures-util/Cargo.toml
new file mode 100644
index 0000000000..125ee8ccb2
--- /dev/null
+++ b/third_party/rust/futures-util/Cargo.toml
@@ -0,0 +1,97 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "futures-util"
+version = "0.3.4"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+description = "Common utilities and extension traits for the futures-rs library.\n"
+homepage = "https://rust-lang.github.io/futures-rs"
+documentation = "https://docs.rs/futures-util/0.3.0"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/futures-rs"
+[package.metadata.docs.rs]
+all-features = true
+[dependencies.futures-channel]
+version = "0.3.4"
+features = ["std"]
+optional = true
+default-features = false
+
+[dependencies.futures-core]
+version = "0.3.4"
+default-features = false
+
+[dependencies.futures-io]
+version = "0.3.4"
+features = ["std"]
+optional = true
+default-features = false
+
+[dependencies.futures-macro]
+version = "0.3.4"
+optional = true
+default-features = false
+
+[dependencies.futures-sink]
+version = "0.3.4"
+optional = true
+default-features = false
+
+[dependencies.futures-task]
+version = "0.3.4"
+default-features = false
+
+[dependencies.futures_01]
+version = "0.1.25"
+optional = true
+package = "futures"
+
+[dependencies.memchr]
+version = "2.2"
+optional = true
+
+[dependencies.pin-utils]
+version = "0.1.0-alpha.4"
+
+[dependencies.proc-macro-hack]
+version = "0.5.9"
+optional = true
+
+[dependencies.proc-macro-nested]
+version = "0.1.2"
+optional = true
+
+[dependencies.slab]
+version = "0.4"
+optional = true
+
+[dependencies.tokio-io]
+version = "0.1.9"
+optional = true
+
+[features]
+alloc = ["futures-core/alloc", "futures-task/alloc"]
+async-await = []
+async-await-macro = ["async-await", "futures-macro", "proc-macro-hack", "proc-macro-nested"]
+bilock = []
+cfg-target-has-atomic = ["futures-core/cfg-target-has-atomic", "futures-task/cfg-target-has-atomic"]
+channel = ["std", "futures-channel"]
+compat = ["std", "futures_01"]
+default = ["std", "async-await", "async-await-macro"]
+io = ["std", "futures-io", "memchr"]
+io-compat = ["io", "compat", "tokio-io"]
+read-initializer = ["io", "futures-io/read-initializer", "futures-io/unstable"]
+sink = ["futures-sink"]
+std = ["alloc", "futures-core/std", "futures-task/std", "slab"]
+unstable = ["futures-core/unstable", "futures-task/unstable"]