summaryrefslogtreecommitdiffstats
path: root/third_party/rust/gfx-backend-dx12/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/gfx-backend-dx12/Cargo.toml')
-rw-r--r--third_party/rust/gfx-backend-dx12/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/rust/gfx-backend-dx12/Cargo.toml b/third_party/rust/gfx-backend-dx12/Cargo.toml
new file mode 100644
index 0000000000..893294e3d2
--- /dev/null
+++ b/third_party/rust/gfx-backend-dx12/Cargo.toml
@@ -0,0 +1,39 @@
+[package]
+name = "gfx-backend-dx12"
+version = "0.6.2"
+description = "DirectX-12 API backend for gfx-rs"
+homepage = "https://github.com/gfx-rs/gfx"
+repository = "https://github.com/gfx-rs/gfx"
+keywords = ["graphics", "gamedev"]
+license = "MIT OR Apache-2.0"
+authors = ["The Gfx-rs Developers"]
+readme = "README.md"
+documentation = "https://docs.rs/gfx-backend-dx12"
+workspace = "../../.."
+edition = "2018"
+
+[features]
+default = []
+
+[lib]
+name = "gfx_backend_dx12"
+
+[dependencies]
+arrayvec = "0.5"
+auxil = { path = "../../auxil/auxil", version = "0.5", package = "gfx-auxil", features = ["spirv_cross"] }
+hal = { path = "../../hal", version = "0.6", package = "gfx-hal" }
+range-alloc = { path = "../../auxil/range-alloc", version = "0.1.1" }
+bitflags = "1"
+bit-set = "0.5"
+native = { package = "d3d12", version = "0.3", features = ["libloading"] }
+log = "0.4"
+parking_lot = "0.11"
+smallvec = "1"
+spirv_cross = { version = "0.22", features = ["hlsl"] }
+winapi = { version = "0.3", features = ["basetsd","d3d12","d3d12sdklayers","d3d12shader","d3dcommon","d3dcompiler","dxgi1_2","dxgi1_3","dxgi1_4","dxgi1_5","dxgi1_6","dxgidebug","dxgiformat","dxgitype","handleapi","minwindef","synchapi","unknwnbase","winbase","windef","winerror","winnt","winuser"] }
+raw-window-handle = "0.3"
+
+# This forces docs.rs to build the crate on windows, otherwise the build fails
+# and we get no docs at all.
+[package.metadata.docs.rs]
+default-target = "x86_64-pc-windows-msvc"