summaryrefslogtreecommitdiffstats
path: root/third_party/rust/gfx-backend-vulkan/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/gfx-backend-vulkan/Cargo.toml')
-rw-r--r--third_party/rust/gfx-backend-vulkan/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/rust/gfx-backend-vulkan/Cargo.toml b/third_party/rust/gfx-backend-vulkan/Cargo.toml
new file mode 100644
index 0000000000..38020fa28a
--- /dev/null
+++ b/third_party/rust/gfx-backend-vulkan/Cargo.toml
@@ -0,0 +1,39 @@
+[package]
+name = "gfx-backend-vulkan"
+version = "0.6.5"
+description = "Vulkan API backend for gfx-rs"
+homepage = "https://github.com/gfx-rs/gfx"
+repository = "https://github.com/gfx-rs/gfx"
+keywords = ["graphics", "gamedev"]
+license = "MIT OR Apache-2.0"
+authors = ["The Gfx-rs Developers"]
+readme = "README.md"
+documentation = "https://docs.rs/gfx-backend-vulkan"
+workspace = "../../.."
+edition = "2018"
+
+[features]
+default = []
+use-rtld-next = ["shared_library"]
+
+[lib]
+name = "gfx_backend_vulkan"
+
+[dependencies]
+arrayvec = "0.5"
+byteorder = "1"
+log = { version = "0.4" }
+lazy_static = "1"
+shared_library = { version = "0.1.9", optional = true }
+ash = "0.31"
+hal = { path = "../../hal", version = "0.6", package = "gfx-hal" }
+smallvec = "1.0"
+raw-window-handle = "0.3"
+inplace_it = "0.3.2"
+
+[target.'cfg(windows)'.dependencies]
+winapi = { version = "0.3", features = ["libloaderapi", "windef", "winuser"] }
+[target.'cfg(target_os = "macos")'.dependencies]
+objc = "0.2.5"
+core-graphics-types = "0.1"
+