summaryrefslogtreecommitdiffstats
path: root/third_party/rust/gfx-hal/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/gfx-hal/Cargo.toml')
-rw-r--r--third_party/rust/gfx-hal/Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/third_party/rust/gfx-hal/Cargo.toml b/third_party/rust/gfx-hal/Cargo.toml
new file mode 100644
index 0000000000..bce6f9760b
--- /dev/null
+++ b/third_party/rust/gfx-hal/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "gfx-hal"
+version = "0.6.0"
+description = "gfx-rs hardware abstraction layer"
+homepage = "https://github.com/gfx-rs/gfx"
+repository = "https://github.com/gfx-rs/gfx"
+keywords = ["graphics"]
+license = "MIT OR Apache-2.0"
+authors = ["The Gfx-rs Developers"]
+documentation = "https://docs.rs/gfx-hal"
+workspace = "../.."
+edition = "2018"
+
+[features]
+unstable = []
+
+[lib]
+name = "gfx_hal"
+path = "src/lib.rs"
+
+[dependencies]
+bitflags = "1.0"
+mint = { version = "0.5", optional = true }
+raw-window-handle = "0.3"
+serde = { version = "1", features = ["serde_derive"], optional = true }
+
+[dev-dependencies]
+gfx-backend-empty = { path = "../backend/empty", version = "0.6" }