summaryrefslogtreecommitdiffstats
path: root/third_party/rust/glean-core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/glean-core/Cargo.toml')
-rw-r--r--third_party/rust/glean-core/Cargo.toml80
1 files changed, 80 insertions, 0 deletions
diff --git a/third_party/rust/glean-core/Cargo.toml b/third_party/rust/glean-core/Cargo.toml
new file mode 100644
index 0000000000..e08b06d25c
--- /dev/null
+++ b/third_party/rust/glean-core/Cargo.toml
@@ -0,0 +1,80 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "glean-core"
+version = "33.10.2"
+authors = ["Jan-Erik Rediger <jrediger@mozilla.com>", "The Glean Team <glean-team@mozilla.com>"]
+include = ["/README.md", "/LICENSE", "/src", "/examples", "/tests", "/Cargo.toml"]
+description = "A modern Telemetry library"
+readme = "README.md"
+keywords = ["telemetry"]
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/glean"
+[package.metadata.glean]
+glean-parser = "1.29.0"
+[dependencies.bincode]
+version = "1.2.1"
+
+[dependencies.chrono]
+version = "0.4.10"
+features = ["serde"]
+
+[dependencies.ffi-support]
+version = "0.4.0"
+
+[dependencies.flate2]
+version = "1.0.19"
+
+[dependencies.log]
+version = "0.4.8"
+
+[dependencies.once_cell]
+version = "1.4.1"
+
+[dependencies.rkv]
+version = "0.16.0"
+default-features = false
+
+[dependencies.serde]
+version = "1.0.104"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0.44"
+
+[dependencies.uuid]
+version = "0.8.1"
+features = ["v4"]
+[dev-dependencies.ctor]
+version = "0.1.12"
+
+[dev-dependencies.env_logger]
+version = "0.7.1"
+features = ["termcolor", "atty", "humantime"]
+default-features = false
+
+[dev-dependencies.iso8601]
+version = "0.4"
+
+[dev-dependencies.tempfile]
+version = "3.1.0"
+
+[features]
+rkv-safe-mode = []
+[badges.circle-ci]
+branch = "main"
+repository = "mozilla/glean"
+
+[badges.maintenance]
+status = "actively-developed"