summaryrefslogtreecommitdiffstats
path: root/third_party/rust/glean/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/glean/Cargo.toml')
-rw-r--r--third_party/rust/glean/Cargo.toml77
1 files changed, 77 insertions, 0 deletions
diff --git a/third_party/rust/glean/Cargo.toml b/third_party/rust/glean/Cargo.toml
new file mode 100644
index 0000000000..b5dd010c82
--- /dev/null
+++ b/third_party/rust/glean/Cargo.toml
@@ -0,0 +1,77 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "glean"
+version = "33.10.2"
+authors = ["Jan-Erik Rediger <jrediger@mozilla.com>", "The Glean Team <glean-team@mozilla.com>"]
+include = ["/README.md", "/LICENSE", "/src", "/tests", "/Cargo.toml"]
+description = "Glean SDK Rust language bindings"
+readme = "README.md"
+keywords = ["telemetry", "glean"]
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/glean"
+[dependencies.chrono]
+version = "0.4.10"
+features = ["serde"]
+
+[dependencies.crossbeam-channel]
+version = "0.5"
+
+[dependencies.glean-core]
+version = "33.10.2"
+
+[dependencies.inherent]
+version = "0.1.4"
+
+[dependencies.log]
+version = "0.4.8"
+
+[dependencies.once_cell]
+version = "1.2.0"
+
+[dependencies.serde]
+version = "1.0.104"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0.44"
+
+[dependencies.thiserror]
+version = "1.0.4"
+
+[dependencies.time]
+version = "0.1.40"
+
+[dependencies.uuid]
+version = "0.8.1"
+features = ["v4"]
+[dev-dependencies.env_logger]
+version = "0.7.1"
+features = ["termcolor", "atty", "humantime"]
+default-features = false
+
+[dev-dependencies.flate2]
+version = "1.0.19"
+
+[dev-dependencies.jsonschema-valid]
+version = "0.4.0"
+
+[dev-dependencies.tempfile]
+version = "3.1.0"
+[badges.circle-ci]
+branch = "main"
+repository = "mozilla/glean"
+
+[badges.maintenance]
+status = "actively-developed"