summaryrefslogtreecommitdiffstats
path: root/third_party/rust/gpu-alloc/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/gpu-alloc/Cargo.toml')
-rw-r--r--third_party/rust/gpu-alloc/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/third_party/rust/gpu-alloc/Cargo.toml b/third_party/rust/gpu-alloc/Cargo.toml
new file mode 100644
index 0000000000..9376be4394
--- /dev/null
+++ b/third_party/rust/gpu-alloc/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "gpu-alloc"
+version = "0.2.1"
+authors = ["Zakarum <zakarumych@ya.ru>"]
+edition = "2018"
+description = "Implementation agnostic memory allocator for Vulkan like APIs"
+keywords = ["gpu", "vulkan", "allocation", "no-std"]
+license = "MIT OR Apache-2.0"
+documentation = "https://docs.rs/gpu-alloc-types/0.2.1"
+homepage = "https://github.com/zakarumych/gpu-alloc"
+repository = "https://github.com/zakarumych/gpu-alloc"
+
+[features]
+std = []
+default = ["std"]
+
+[dependencies]
+gpu-alloc-types = { path = "../types", version = "0.1" }
+tracing = { version = "0.1", optional = true, default-features = false }
+bitflags = { version = "1.2", default-features = false }
+serde = { version = "1.0", optional = true, default-features = false, features = ["derive"] }