summaryrefslogtreecommitdiffstats
path: root/third_party/rust/jsparagus/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/jsparagus/Cargo.toml')
-rw-r--r--third_party/rust/jsparagus/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/third_party/rust/jsparagus/Cargo.toml b/third_party/rust/jsparagus/Cargo.toml
new file mode 100644
index 0000000000..289f04a5bc
--- /dev/null
+++ b/third_party/rust/jsparagus/Cargo.toml
@@ -0,0 +1,36 @@
+[package]
+name = "jsparagus"
+authors = ["The jsparagus Project Developers"]
+version = "0.1.0"
+description = "A JavaScript parser"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/mozilla-spidermonkey/jsparagus"
+publish = false
+edition = "2018"
+
+[workspace]
+
+[lib]
+
+[[bin]]
+name = "smoosh_tools"
+path = "src/bin/smoosh_tools.rs"
+
+[dependencies]
+jsparagus-ast = { path = "crates/ast" }
+jsparagus-driver = { path = "crates/driver", optional = true }
+jsparagus-emitter = { path = "crates/emitter" }
+jsparagus-generated-parser = { path = "crates/generated_parser" }
+jsparagus-interpreter = { path = "crates/interpreter", optional = true }
+jsparagus-json-log = { path = "crates/json-log" }
+jsparagus-parser = { path = "crates/parser" }
+jsparagus-scope = { path = "crates/scope" }
+jsparagus-stencil = { path = "crates/stencil" }
+
+[features]
+default = []
+logging = ["jsparagus-parser/logging"]
+full = ["jsparagus-driver", "jsparagus-interpreter"]
+
+[profile.release]
+debug = true # enable debug symbols in release builds