summaryrefslogtreecommitdiffstats
path: root/third_party/rust/libz-sys/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/libz-sys/Cargo.toml')
-rw-r--r--third_party/rust/libz-sys/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/third_party/rust/libz-sys/Cargo.toml b/third_party/rust/libz-sys/Cargo.toml
new file mode 100644
index 0000000000..0c2477cc53
--- /dev/null
+++ b/third_party/rust/libz-sys/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "libz-sys"
+version = "1.0.25"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+build = "build.rs"
+links = "z"
+description = "Bindings to the system libz library (also known as zlib).\n"
+documentation = "https://docs.rs/libz-sys"
+categories = ["external-ffi-bindings"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/alexcrichton/libz-sys"
+[dependencies.libc]
+version = "0.2.43"
+[build-dependencies.cc]
+version = "1.0.18"
+
+[build-dependencies.pkg-config]
+version = "0.3.9"
+
+[features]
+asm = []
+static = []
+[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
+version = "0.2"