summaryrefslogtreecommitdiffstats
path: root/third_party/rust/libz-sys/appveyor.yml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/libz-sys/appveyor.yml')
-rw-r--r--third_party/rust/libz-sys/appveyor.yml30
1 files changed, 30 insertions, 0 deletions
diff --git a/third_party/rust/libz-sys/appveyor.yml b/third_party/rust/libz-sys/appveyor.yml
new file mode 100644
index 0000000000..1638233061
--- /dev/null
+++ b/third_party/rust/libz-sys/appveyor.yml
@@ -0,0 +1,30 @@
+environment:
+ matrix:
+ - TARGET: x86_64-pc-windows-gnu
+ MSYS_BITS: 64
+ - TARGET: i686-pc-windows-gnu
+ MSYS_BITS: 32
+ - TARGET: x86_64-pc-windows-msvc
+ - TARGET: i686-pc-windows-msvc
+ - TARGET: x86_64-pc-windows-msvc
+ VCPKG_DEFAULT_TRIPLET: x64-windows-static
+ RUSTFLAGS: -Ctarget-feature=+crt-static
+install:
+ - git submodule update --init --recursive
+ - ps: Start-FileDownload "https://static.rust-lang.org/dist/rust-nightly-${env:TARGET}.exe"
+ - rust-nightly-%TARGET%.exe /VERYSILENT /NORESTART /DIR="C:\Program Files (x86)\Rust"
+ - set PATH=%PATH%;C:\Program Files (x86)\Rust\bin
+ - if defined MSYS_BITS set PATH=%PATH%;C:\msys64\mingw%MSYS_BITS%\bin;C:\msys64\usr\bin
+ - rustc -V
+ - cargo -V
+ - if defined VCPKG_DEFAULT_TRIPLET git clone https://github.com/Microsoft/vcpkg c:\projects\vcpkg
+ - if defined VCPKG_DEFAULT_TRIPLET c:\projects\vcpkg\bootstrap-vcpkg.bat
+ - if defined VCPKG_DEFAULT_TRIPLET set VCPKG_ROOT=c:\projects\vcpkg
+ - if defined VCPKG_DEFAULT_TRIPLET echo yes > %VCPKG_ROOT%\Downloads\AlwaysAllowDownloads
+ - if defined VCPKG_DEFAULT_TRIPLET %VCPKG_ROOT%\vcpkg.exe install zlib
+
+build: false
+
+test_script:
+ - cargo test --target %TARGET%
+ - cargo run --manifest-path systest/Cargo.toml --target %TARGET%