summaryrefslogtreecommitdiffstats
path: root/third_party/rust/lucet-module-wasmsbx/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/lucet-module-wasmsbx/Cargo.toml')
-rw-r--r--third_party/rust/lucet-module-wasmsbx/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/third_party/rust/lucet-module-wasmsbx/Cargo.toml b/third_party/rust/lucet-module-wasmsbx/Cargo.toml
new file mode 100644
index 0000000000..5dd20ba20a
--- /dev/null
+++ b/third_party/rust/lucet-module-wasmsbx/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+name = "lucet-module-wasmsbx"
+version = "0.1.1"
+description = "A structured interface for Lucet modules"
+homepage = "https://github.com/fastly/lucet"
+repository = "https://github.com/fastly/lucet"
+license = "Apache-2.0 WITH LLVM-exception"
+categories = ["wasm"]
+authors = ["Lucet team <lucet@fastly.com>"]
+edition = "2018"
+
+[dependencies]
+cranelift-entity = { path = "../cranelift/cranelift-entity", version = "0.41.0" }
+failure = "0.1"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+bincode = "1.1.4"
+num-derive = "0.3"
+num-traits = "0.2"
+# minisign = { version = "0.5.11", optional = true }
+object = ">=0.12, <0.18"
+byteorder = "1.3"
+
+[features]
+# default = ["signature_checking"]
+default = []
+signature_checking = []