summaryrefslogtreecommitdiffstats
path: root/third_party/rust/memmap/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/memmap/Cargo.toml')
-rw-r--r--third_party/rust/memmap/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/third_party/rust/memmap/Cargo.toml b/third_party/rust/memmap/Cargo.toml
new file mode 100644
index 0000000000..fef331e356
--- /dev/null
+++ b/third_party/rust/memmap/Cargo.toml
@@ -0,0 +1,33 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "memmap"
+version = "0.7.0"
+authors = ["Dan Burkert <dan@danburkert.com>"]
+description = "Cross-platform Rust API for memory-mapped file IO"
+documentation = "https://docs.rs/memmap"
+keywords = ["mmap", "memory-map", "io", "file"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/danburkert/memmap-rs"
+[dev-dependencies.tempdir]
+version = "0.3"
+[target."cfg(unix)".dependencies.libc]
+version = "0.2"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["basetsd", "handleapi", "memoryapi", "minwindef", "std", "sysinfoapi"]
+[badges.appveyor]
+repository = "danburkert/mmap"
+
+[badges.travis-ci]
+repository = "danburkert/memmap-rs"