summaryrefslogtreecommitdiffstats
path: root/third_party/rust/miow-0.2.1/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/miow-0.2.1/Cargo.toml')
-rw-r--r--third_party/rust/miow-0.2.1/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/third_party/rust/miow-0.2.1/Cargo.toml b/third_party/rust/miow-0.2.1/Cargo.toml
new file mode 100644
index 0000000000..6e4252325d
--- /dev/null
+++ b/third_party/rust/miow-0.2.1/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "miow"
+version = "0.2.1"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+license = "MIT/Apache-2.0"
+readme = "README.md"
+keywords = ["iocp", "windows", "io", "overlapped"]
+repository = "https://github.com/alexcrichton/miow"
+homepage = "https://github.com/alexcrichton/miow"
+documentation = "https://docs.rs/miow/0.1/x86_64-pc-windows-msvc/miow/"
+description = """
+A zero overhead I/O library for Windows, focusing on IOCP and Async I/O
+abstractions.
+"""
+
+[dependencies]
+winapi = "0.2"
+kernel32-sys = "0.2"
+ws2_32-sys = "0.2"
+net2 = { version = "0.2.5", default-features = false }
+
+[dev-dependencies]
+rand = "0.3"