summaryrefslogtreecommitdiffstats
path: root/third_party/rust/nodrop/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/nodrop/Cargo.toml')
-rw-r--r--third_party/rust/nodrop/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/third_party/rust/nodrop/Cargo.toml b/third_party/rust/nodrop/Cargo.toml
new file mode 100644
index 0000000000..d1a5f4a861
--- /dev/null
+++ b/third_party/rust/nodrop/Cargo.toml
@@ -0,0 +1,33 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "nodrop"
+version = "0.1.12"
+authors = ["bluss"]
+description = "A wrapper type to inhibit drop (destructor). Use std::mem::ManuallyDrop instead!"
+documentation = "https://docs.rs/nodrop/"
+keywords = ["container", "drop", "no_std"]
+categories = ["rust-patterns"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/bluss/arrayvec"
+[package.metadata.release]
+no-dev-version = true
+[dependencies.nodrop-union]
+version = "0.1.8"
+optional = true
+
+[features]
+std = []
+use_union = ["nodrop-union"]
+use_needs_drop = []
+default = ["std"]