summaryrefslogtreecommitdiffstats
path: root/third_party/rust/object/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/object/Cargo.toml')
-rw-r--r--third_party/rust/object/Cargo.toml69
1 files changed, 69 insertions, 0 deletions
diff --git a/third_party/rust/object/Cargo.toml b/third_party/rust/object/Cargo.toml
new file mode 100644
index 0000000000..c8688f079b
--- /dev/null
+++ b/third_party/rust/object/Cargo.toml
@@ -0,0 +1,69 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "object"
+version = "0.16.0"
+authors = ["Nick Fitzgerald <fitzgen@gmail.com>", "Philip Craig <philipjcraig@gmail.com>"]
+exclude = ["/.coveralls.yml", "/.travis.yml"]
+description = "A unified interface for parsing object file formats."
+keywords = ["object", "loader", "elf", "mach-o", "pe"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/gimli-rs/object"
+[package.metadata.docs.rs]
+all-features = true
+
+[[example]]
+name = "objcopy"
+required-features = ["read", "write"]
+[dependencies.crc32fast]
+version = "1.2"
+optional = true
+
+[dependencies.flate2]
+version = "1"
+optional = true
+
+[dependencies.goblin]
+version = "0.1"
+features = ["endian_fd", "elf32", "elf64", "mach32", "mach64", "pe32", "pe64", "archive"]
+default-features = false
+
+[dependencies.indexmap]
+version = "1.1"
+optional = true
+
+[dependencies.parity-wasm]
+version = "0.41.0"
+optional = true
+
+[dependencies.scroll]
+version = "0.10"
+default-features = false
+
+[dependencies.target-lexicon]
+version = "0.9"
+
+[dependencies.uuid]
+version = "0.8"
+default-features = false
+[dev-dependencies.memmap]
+version = "0.7"
+
+[features]
+compression = ["flate2"]
+default = ["read", "std", "compression", "wasm"]
+read = []
+std = ["goblin/std"]
+wasm = ["std", "parity-wasm"]
+write = ["crc32fast", "indexmap", "std"]