summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ordered-float/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/ordered-float/README.md')
-rw-r--r--third_party/rust/ordered-float/README.md29
1 files changed, 29 insertions, 0 deletions
diff --git a/third_party/rust/ordered-float/README.md b/third_party/rust/ordered-float/README.md
new file mode 100644
index 0000000000..b5e33021bf
--- /dev/null
+++ b/third_party/rust/ordered-float/README.md
@@ -0,0 +1,29 @@
+# Ordered Floats
+
+Provides several wrapper types for Ord and Eq implementations on f64.
+
+## Usage
+
+Use the crates.io repository; add this to your `Cargo.toml` along
+with the rest of your dependencies:
+
+```toml
+[dependencies]
+ordered-float = "1.0"
+```
+
+See the [API documentation](https://docs.rs/ordered-float) for further details.
+
+## no_std
+
+To use `ordered_float` without requiring the Rust standard library, disable
+the default `std` feature:
+
+```toml
+[dependencies]
+ordered-float = { version = "1.0", default-features = false }
+```
+
+## License
+
+MIT