summaryrefslogtreecommitdiffstats
path: root/third_party/rust/paste
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/paste')
-rw-r--r--third_party/rust/paste/.cargo-checksum.json1
-rw-r--r--third_party/rust/paste/Cargo.toml33
-rw-r--r--third_party/rust/paste/LICENSE-APACHE201
-rw-r--r--third_party/rust/paste/LICENSE-MIT25
-rw-r--r--third_party/rust/paste/README.md154
-rw-r--r--third_party/rust/paste/src/lib.rs150
-rw-r--r--third_party/rust/paste/tests/compiletest.rs6
-rw-r--r--third_party/rust/paste/tests/test.rs307
-rw-r--r--third_party/rust/paste/tests/ui/case-warning.rs13
-rw-r--r--third_party/rust/paste/tests/ui/case-warning.stderr16
-rw-r--r--third_party/rust/paste/tests/ui/no-env-var.rs5
-rw-r--r--third_party/rust/paste/tests/ui/no-env-var.stderr5
-rw-r--r--third_party/rust/paste/tests/ui/unexpected-modifier.rs5
-rw-r--r--third_party/rust/paste/tests/ui/unexpected-modifier.stderr5
-rw-r--r--third_party/rust/paste/tests/ui/unsupported-modifier.rs5
-rw-r--r--third_party/rust/paste/tests/ui/unsupported-modifier.stderr5
16 files changed, 936 insertions, 0 deletions
diff --git a/third_party/rust/paste/.cargo-checksum.json b/third_party/rust/paste/.cargo-checksum.json
new file mode 100644
index 0000000000..f495909ff1
--- /dev/null
+++ b/third_party/rust/paste/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"477260b435d48cb99849ea0459048d6b11107a50fdc3ba65e36687aff6b343e3","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"7f697f191d6ffb32881a6bcf535e817ebbebaaa11b9aacf4f0b26fd32e2cc201","README.md":"5c26782fd4a0c9f5a2de81d692c1069c0ad846a4a00d75fe1f0b5f8f197e0041","src/lib.rs":"1863f79ae0c878576689f41262dbdda46c1340c4dba8fe0a1c44397648e9cbf1","tests/compiletest.rs":"0a52a44786aea1c299c695bf948b2ed2081e4cc344e5c2cadceab4eb03d0010d","tests/test.rs":"0470e71f6a8b55c75ec2a736e787705db0d3ee9f24505fa2661521de4265d0c4","tests/ui/case-warning.rs":"905a6721d6ca7820cb37acfa9d684ba0e6c6ef043e75d494b697d0b97a8894d0","tests/ui/case-warning.stderr":"c86e816d08af760a01840b1de831c57751469ed6cb1fe1e51af527cee2359dac","tests/ui/no-env-var.rs":"3b93779a3889236256520addafa3210fa95115b4a37b43890e726c0e4c6b41c4","tests/ui/no-env-var.stderr":"99283b6275c2572129109327d647bbcc789e2321ac1267be61d3f856c64c4108","tests/ui/unexpected-modifier.rs":"61c2a233cd947fdf04c44472608fbf04d797bfa3dac8d66ccdb91b01c7a27ca0","tests/ui/unexpected-modifier.stderr":"33b47ba0cfea8e93cd9e30456cc522e35d4ef7c64d5a46eb943e46ab20dc037e","tests/ui/unsupported-modifier.rs":"5b7159f9467ffaa790c82c0126a99e770a0637eadc4c0f9b5cdf43d0034fdc9e","tests/ui/unsupported-modifier.stderr":"5020c31d20e558846b82036dd940e09d92e40e09b5431f4c8450bbc6a3ba5114"},"package":"0a229b1c58c692edcaa5b9b0948084f130f55d2dcc15b02fcc5340b2b4521476"} \ No newline at end of file
diff --git a/third_party/rust/paste/Cargo.toml b/third_party/rust/paste/Cargo.toml
new file mode 100644
index 0000000000..3b7b5ad7c0
--- /dev/null
+++ b/third_party/rust/paste/Cargo.toml
@@ -0,0 +1,33 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "paste"
+version = "0.1.12"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+description = "Macros for all your token pasting needs"
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/paste"
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
+[dependencies.paste-impl]
+version = "=0.1.12"
+
+[dependencies.proc-macro-hack]
+version = "0.5.9"
+[dev-dependencies.rustversion]
+version = "1.0"
+
+[dev-dependencies.trybuild]
+version = "1.0"
diff --git a/third_party/rust/paste/LICENSE-APACHE b/third_party/rust/paste/LICENSE-APACHE
new file mode 100644
index 0000000000..16fe87b06e
--- /dev/null
+++ b/third_party/rust/paste/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/third_party/rust/paste/LICENSE-MIT b/third_party/rust/paste/LICENSE-MIT
new file mode 100644
index 0000000000..815d6c02a7
--- /dev/null
+++ b/third_party/rust/paste/LICENSE-MIT
@@ -0,0 +1,25 @@
+Copyright (c) 2018
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/third_party/rust/paste/README.md b/third_party/rust/paste/README.md
new file mode 100644
index 0000000000..8ccc56807a
--- /dev/null
+++ b/third_party/rust/paste/README.md
@@ -0,0 +1,154 @@
+Macros for all your token pasting needs
+=======================================
+
+[![Build Status](https://api.travis-ci.org/dtolnay/paste.svg?branch=master)](https://travis-ci.org/dtolnay/paste)
+[![Latest Version](https://img.shields.io/crates/v/paste.svg)](https://crates.io/crates/paste)
+[![Rust Documentation](https://img.shields.io/badge/api-rustdoc-blue.svg)](https://docs.rs/paste)
+
+The nightly-only [`concat_idents!`] macro in the Rust standard library is
+notoriously underpowered in that its concatenated identifiers can only refer to
+existing items, they can never be used to define something new.
+
+[`concat_idents!`]: https://doc.rust-lang.org/std/macro.concat_idents.html
+
+This crate provides a flexible way to paste together identifiers in a macro,
+including using pasted identifiers to define new items.
+
+```toml
+[dependencies]
+paste = "0.1"
+```
+
+This approach works with any stable or nightly Rust compiler 1.30+.
+
+<br>
+
+## Pasting identifiers
+
+There are two entry points, `paste::expr!` for macros in expression position and
+`paste::item!` for macros in item position.
+
+Within either one, identifiers inside `[<`...`>]` are pasted together to form a
+single identifier.
+
+```rust
+// Macro in item position: at module scope or inside of an impl block.
+paste::item! {
+ // Defines a const called `QRST`.
+ const [<Q R S T>]: &str = "success!";
+}
+
+fn main() {
+ // Macro in expression position: inside a function body.
+ assert_eq!(
+ paste::expr! { [<Q R S T>].len() },
+ 8,
+ );
+}
+```
+
+<br>
+
+## More elaborate examples
+
+This program demonstrates how you may want to bundle a paste invocation inside
+of a more convenient user-facing macro of your own. Here the `routes!(A, B)`
+macro expands to a vector containing `ROUTE_A` and `ROUTE_B`.
+
+```rust
+const ROUTE_A: &str = "/a";
+const ROUTE_B: &str = "/b";
+
+macro_rules! routes {
+ ($($route:ident),*) => {{
+ paste::expr! {
+ vec![$( [<ROUTE_ $route>] ),*]
+ }
+ }}
+}
+
+fn main() {
+ let routes = routes!(A, B);
+ assert_eq!(routes, vec!["/a", "/b"]);
+}
+```
+
+The next example shows a macro that generates accessor methods for some struct
+fields.
+
+```rust
+macro_rules! make_a_struct_and_getters {
+ ($name:ident { $($field:ident),* }) => {
+ // Define a struct. This expands to:
+ //
+ // pub struct S {
+ // a: String,
+ // b: String,
+ // c: String,
+ // }
+ pub struct $name {
+ $(
+ $field: String,
+ )*
+ }
+
+ // Build an impl block with getters. This expands to:
+ //
+ // impl S {
+ // pub fn get_a(&self) -> &str { &self.a }
+ // pub fn get_b(&self) -> &str { &self.b }
+ // pub fn get_c(&self) -> &str { &self.c }
+ // }
+ paste::item! {
+ impl $name {
+ $(
+ pub fn [<get_ $field>](&self) -> &str {
+ &self.$field
+ }
+ )*
+ }
+ }
+ }
+}
+
+make_a_struct_and_getters!(S { a, b, c });
+
+fn call_some_getters(s: &S) -> bool {
+ s.get_a() == s.get_b() && s.get_c().is_empty()
+}
+```
+
+<br>
+
+## Case conversion
+
+Use `$var:lower` or `$var:upper` in the segment list to convert an interpolated
+segment to lower- or uppercase as part of the paste. For example, `[<ld_
+$reg:lower _expr>]` would paste to `ld_bc_expr` if invoked with $reg=`Bc`.
+
+Use `$var:snake` to convert CamelCase input to snake\_case.
+Use `$var:camel` to convert snake\_case to CamelCase.
+These compose, so for example `$var:snake:upper` would give you SCREAMING\_CASE.
+
+The precise Unicode conversions are as defined by [`str::to_lowercase`] and
+[`str::to_uppercase`].
+
+[`str::to_lowercase`]: https://doc.rust-lang.org/std/primitive.str.html#method.to_lowercase
+[`str::to_uppercase`]: https://doc.rust-lang.org/std/primitive.str.html#method.to_uppercase
+
+<br>
+
+#### License
+
+<sup>
+Licensed under either of <a href="LICENSE-APACHE">Apache License, Version
+2.0</a> or <a href="LICENSE-MIT">MIT license</a> at your option.
+</sup>
+
+<br>
+
+<sub>
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in this crate by you, as defined in the Apache-2.0 license, shall
+be dual licensed as above, without any additional terms or conditions.
+</sub>
diff --git a/third_party/rust/paste/src/lib.rs b/third_party/rust/paste/src/lib.rs
new file mode 100644
index 0000000000..6d73ee33f0
--- /dev/null
+++ b/third_party/rust/paste/src/lib.rs
@@ -0,0 +1,150 @@
+//! The nightly-only [`concat_idents!`] macro in the Rust standard library is
+//! notoriously underpowered in that its concatenated identifiers can only refer to
+//! existing items, they can never be used to define something new.
+//!
+//! [`concat_idents!`]: https://doc.rust-lang.org/std/macro.concat_idents.html
+//!
+//! This crate provides a flexible way to paste together identifiers in a macro,
+//! including using pasted identifiers to define new items.
+//!
+//! This approach works with any stable or nightly Rust compiler 1.30+.
+//!
+//! <br>
+//!
+//! # Pasting identifiers
+//!
+//! There are two entry points, `paste::expr!` for macros in expression position and
+//! `paste::item!` for macros in item position.
+//!
+//! Within either one, identifiers inside `[<`...`>]` are pasted together to form a
+//! single identifier.
+//!
+//! ```
+//! // Macro in item position: at module scope or inside of an impl block.
+//! paste::item! {
+//! // Defines a const called `QRST`.
+//! const [<Q R S T>]: &str = "success!";
+//! }
+//!
+//! fn main() {
+//! // Macro in expression position: inside a function body.
+//! assert_eq!(
+//! paste::expr! { [<Q R S T>].len() },
+//! 8,
+//! );
+//! }
+//! ```
+//!
+//! <br><br>
+//!
+//! # More elaborate examples
+//!
+//! This program demonstrates how you may want to bundle a paste invocation inside
+//! of a more convenient user-facing macro of your own. Here the `routes!(A, B)`
+//! macro expands to a vector containing `ROUTE_A` and `ROUTE_B`.
+//!
+//! ```
+//! const ROUTE_A: &str = "/a";
+//! const ROUTE_B: &str = "/b";
+//!
+//! macro_rules! routes {
+//! ($($route:ident),*) => {{
+//! paste::expr! {
+//! vec![$( [<ROUTE_ $route>] ),*]
+//! }
+//! }}
+//! }
+//!
+//! fn main() {
+//! let routes = routes!(A, B);
+//! assert_eq!(routes, vec!["/a", "/b"]);
+//! }
+//! ```
+//!
+//! The next example shows a macro that generates accessor methods for some struct
+//! fields.
+//!
+//! ```
+//! macro_rules! make_a_struct_and_getters {
+//! ($name:ident { $($field:ident),* }) => {
+//! // Define a struct. This expands to:
+//! //
+//! // pub struct S {
+//! // a: String,
+//! // b: String,
+//! // c: String,
+//! // }
+//! pub struct $name {
+//! $(
+//! $field: String,
+//! )*
+//! }
+//!
+//! // Build an impl block with getters. This expands to:
+//! //
+//! // impl S {
+//! // pub fn get_a(&self) -> &str { &self.a }
+//! // pub fn get_b(&self) -> &str { &self.b }
+//! // pub fn get_c(&self) -> &str { &self.c }
+//! // }
+//! paste::item! {
+//! impl $name {
+//! $(
+//! pub fn [<get_ $field>](&self) -> &str {
+//! &self.$field
+//! }
+//! )*
+//! }
+//! }
+//! }
+//! }
+//!
+//! make_a_struct_and_getters!(S { a, b, c });
+//!
+//! fn call_some_getters(s: &S) -> bool {
+//! s.get_a() == s.get_b() && s.get_c().is_empty()
+//! }
+//! #
+//! # fn main() {}
+//! ```
+//!
+//! <br><br>
+//!
+//! # Case conversion
+//!
+//! Use `$var:lower` or `$var:upper` in the segment list to convert an
+//! interpolated segment to lower- or uppercase as part of the paste. For
+//! example, `[<ld_ $reg:lower _expr>]` would paste to `ld_bc_expr` if invoked
+//! with $reg=`Bc`.
+//!
+//! Use `$var:snake` to convert CamelCase input to snake\_case.
+//! Use `$var:camel` to convert snake\_case to CamelCase.
+//! These compose, so for example `$var:snake:upper` would give you SCREAMING\_CASE.
+//!
+//! The precise Unicode conversions are as defined by [`str::to_lowercase`] and
+//! [`str::to_uppercase`].
+//!
+//! [`str::to_lowercase`]: https://doc.rust-lang.org/std/primitive.str.html#method.to_lowercase
+//! [`str::to_uppercase`]: https://doc.rust-lang.org/std/primitive.str.html#method.to_uppercase
+
+#![no_std]
+
+use proc_macro_hack::proc_macro_hack;
+
+/// Paste identifiers within a macro invocation that expands to an expression.
+#[proc_macro_hack]
+pub use paste_impl::expr;
+
+/// Paste identifiers within a macro invocation that expands to one or more
+/// items.
+///
+/// An item is like a struct definition, function, impl block, or anything else
+/// that can appear at the top level of a module scope.
+pub use paste_impl::item;
+
+/// Paste identifiers within a macro invocation that expands to one or more
+/// macro_rules macros or items containing macros.
+pub use paste_impl::item_with_macros;
+
+#[doc(hidden)]
+pub use paste_impl::EnumHack;
diff --git a/third_party/rust/paste/tests/compiletest.rs b/third_party/rust/paste/tests/compiletest.rs
new file mode 100644
index 0000000000..f9aea23b51
--- /dev/null
+++ b/third_party/rust/paste/tests/compiletest.rs
@@ -0,0 +1,6 @@
+#[rustversion::attr(not(nightly), ignore)]
+#[test]
+fn ui() {
+ let t = trybuild::TestCases::new();
+ t.compile_fail("tests/ui/*.rs");
+}
diff --git a/third_party/rust/paste/tests/test.rs b/third_party/rust/paste/tests/test.rs
new file mode 100644
index 0000000000..3aecd8d8e9
--- /dev/null
+++ b/third_party/rust/paste/tests/test.rs
@@ -0,0 +1,307 @@
+mod test_basic {
+ struct Struct;
+
+ paste::item! {
+ impl Struct {
+ fn [<a b c>]() {}
+ }
+ }
+
+ #[test]
+ fn test() {
+ Struct::abc();
+ }
+}
+
+mod test_in_impl {
+ struct Struct;
+
+ impl Struct {
+ paste::item! {
+ fn [<a b c>]() {}
+ }
+ }
+
+ #[test]
+ fn test() {
+ Struct::abc();
+ }
+}
+
+#[test]
+fn test_shared_hygiene() {
+ paste::expr! {
+ let [<a a>] = 1;
+ assert_eq!([<a a>], 1);
+ }
+}
+
+#[test]
+fn test_repeat() {
+ const ROCKET_A: &'static str = "/a";
+ const ROCKET_B: &'static str = "/b";
+
+ macro_rules! routes {
+ ($($route:ident),*) => {{
+ paste::expr! {
+ vec![$( [<ROCKET_ $route>] ),*]
+ }
+ }}
+ }
+
+ let routes = routes!(A, B);
+ assert_eq!(routes, vec!["/a", "/b"]);
+}
+
+#[test]
+fn test_integer() {
+ const CONST0: &'static str = "const0";
+
+ let pasted = paste::expr!([<CONST 0>]);
+ assert_eq!(pasted, CONST0);
+}
+
+#[test]
+fn test_underscore() {
+ paste::expr! {
+ const A_B: usize = 0;
+ assert_eq!([<A _ B>], 0);
+ }
+}
+
+#[test]
+fn test_lifetime() {
+ paste::expr! {
+ #[allow(dead_code)]
+ struct S<[<'d e>]> {
+ q: &[<'d e>] str,
+ }
+ }
+}
+
+#[test]
+fn test_keyword() {
+ paste::expr! {
+ struct [<F move>];
+
+ let _ = Fmove;
+ }
+}
+
+#[test]
+fn test_literal_str() {
+ paste::expr! {
+ struct [<Foo "Bar-Baz">];
+
+ let _ = FooBar_Baz;
+ }
+}
+
+#[test]
+fn test_env_literal() {
+ paste::expr! {
+ struct [<Lib env bar>];
+
+ let _ = Libenvbar;
+ }
+}
+
+#[test]
+fn test_env_present() {
+ paste::expr! {
+ struct [<Lib env!("CARGO_PKG_NAME")>];
+
+ let _ = Libpaste;
+ }
+}
+
+#[test]
+fn test_raw_identifier() {
+ paste::expr! {
+ struct [<F r#move>];
+
+ let _ = Fmove;
+ }
+}
+
+#[test]
+fn test_false_start() {
+ trait Trait {
+ fn f() -> usize;
+ }
+
+ struct S;
+
+ impl Trait for S {
+ fn f() -> usize {
+ 0
+ }
+ }
+
+ paste::expr! {
+ let x = [<S as Trait>::f()];
+ assert_eq!(x[0], 0);
+ }
+}
+
+#[test]
+fn test_local_variable() {
+ let yy = 0;
+
+ paste::expr! {
+ assert_eq!([<y y>], 0);
+ }
+}
+
+mod test_none_delimited_single_ident {
+ macro_rules! m {
+ ($id:ident) => {
+ paste::item! {
+ fn f() -> &'static str {
+ stringify!($id)
+ }
+ }
+ };
+ }
+
+ m!(i32x4);
+
+ #[test]
+ fn test() {
+ assert_eq!(f(), "i32x4");
+ }
+}
+
+mod test_none_delimited_single_lifetime {
+ macro_rules! m {
+ ($life:lifetime) => {
+ paste::item! {
+ pub struct S;
+ impl<$life> S {
+ fn f() {}
+ }
+ }
+ };
+ }
+
+ m!('a);
+
+ #[test]
+ fn test() {
+ S::f();
+ }
+}
+
+mod test_to_lower {
+ macro_rules! m {
+ ($id:ident) => {
+ paste::item! {
+ fn [<my_ $id:lower _here>](_arg: u8) -> &'static str {
+ stringify!([<$id:lower>])
+ }
+ }
+ };
+ }
+
+ m!(Test);
+
+ #[test]
+ fn test_to_lower() {
+ assert_eq!(my_test_here(0), "test");
+ }
+}
+
+#[test]
+fn test_env_to_lower() {
+ paste::expr! {
+ struct [<Lib env!("CARGO_PKG_NAME"):lower>];
+
+ let _ = Libpaste;
+ }
+}
+
+mod test_to_upper {
+ macro_rules! m {
+ ($id:ident) => {
+ paste::item! {
+ const [<MY_ $id:upper _HERE>]: &str = stringify!([<$id:upper>]);
+ }
+ };
+ }
+
+ m!(Test);
+
+ #[test]
+ fn test_to_upper() {
+ assert_eq!(MY_TEST_HERE, "TEST");
+ }
+}
+
+#[test]
+fn test_env_to_upper() {
+ paste::expr! {
+ const [<LIB env!("CARGO_PKG_NAME"):upper>]: &str = "libpaste";
+
+ let _ = LIBPASTE;
+ }
+}
+
+mod test_to_snake {
+ macro_rules! m {
+ ($id:ident) => {
+ paste::item! {
+ const DEFAULT_SNAKE: &str = stringify!([<$id:snake>]);
+ const LOWER_SNAKE: &str = stringify!([<$id:snake:lower>]);
+ const UPPER_SNAKE: &str = stringify!([<$id:snake:upper>]);
+ }
+ };
+ }
+
+ m!(ThisIsButATest);
+
+ #[test]
+ fn test_to_snake() {
+ assert_eq!(DEFAULT_SNAKE, "this_is_but_a_test");
+ assert_eq!(LOWER_SNAKE, "this_is_but_a_test");
+ assert_eq!(UPPER_SNAKE, "THIS_IS_BUT_A_TEST");
+ }
+}
+
+#[test]
+fn test_env_to_snake() {
+ paste::expr! {
+ const [<LIB env!("CARGO_PKG_NAME"):snake:upper>]: &str = "libpaste";
+
+ let _ = LIBPASTE;
+ }
+}
+
+mod test_to_camel {
+ macro_rules! m {
+ ($id:ident) => {
+ paste::item! {
+ const DEFAULT_CAMEL: &str = stringify!([<$id:camel>]);
+ const LOWER_CAMEL: &str = stringify!([<$id:camel:lower>]);
+ const UPPER_CAMEL: &str = stringify!([<$id:camel:upper>]);
+ }
+ };
+ }
+
+ m!(this_is_but_a_test);
+
+ #[test]
+ fn test_to_camel() {
+ assert_eq!(DEFAULT_CAMEL, "ThisIsButATest");
+ assert_eq!(LOWER_CAMEL, "thisisbutatest");
+ assert_eq!(UPPER_CAMEL, "THISISBUTATEST");
+ }
+}
+
+#[test]
+fn test_env_to_camel() {
+ paste::expr! {
+ const [<LIB env!("CARGO_PKG_NAME"):camel>]: &str = "libpaste";
+
+ let _ = LIBPaste;
+ }
+}
diff --git a/third_party/rust/paste/tests/ui/case-warning.rs b/third_party/rust/paste/tests/ui/case-warning.rs
new file mode 100644
index 0000000000..4b41ab683d
--- /dev/null
+++ b/third_party/rust/paste/tests/ui/case-warning.rs
@@ -0,0 +1,13 @@
+#![deny(warnings)]
+
+macro_rules! m {
+ ($i:ident) => {
+ paste::item! {
+ pub fn [<foo $i>]() {}
+ }
+ };
+}
+
+m!(Bar);
+
+fn main() {}
diff --git a/third_party/rust/paste/tests/ui/case-warning.stderr b/third_party/rust/paste/tests/ui/case-warning.stderr
new file mode 100644
index 0000000000..5bf37a083c
--- /dev/null
+++ b/third_party/rust/paste/tests/ui/case-warning.stderr
@@ -0,0 +1,16 @@
+error: function `fooBar` should have a snake case name
+ --> $DIR/case-warning.rs:6:20
+ |
+6 | pub fn [<foo $i>]() {}
+ | ^^^^^^^^^^ help: convert the identifier to snake case: `foo_bar`
+...
+11 | m!(Bar);
+ | -------- in this macro invocation
+ |
+note: the lint level is defined here
+ --> $DIR/case-warning.rs:1:9
+ |
+1 | #![deny(warnings)]
+ | ^^^^^^^^
+ = note: `#[deny(non_snake_case)]` implied by `#[deny(warnings)]`
+ = note: this error originates in a macro (in Nightly builds, run with -Z macro-backtrace for more info)
diff --git a/third_party/rust/paste/tests/ui/no-env-var.rs b/third_party/rust/paste/tests/ui/no-env-var.rs
new file mode 100644
index 0000000000..87aad35091
--- /dev/null
+++ b/third_party/rust/paste/tests/ui/no-env-var.rs
@@ -0,0 +1,5 @@
+paste::item! {
+ fn [<a env!("PASTE_UNKNOWN") b>]() {}
+}
+
+fn main() {}
diff --git a/third_party/rust/paste/tests/ui/no-env-var.stderr b/third_party/rust/paste/tests/ui/no-env-var.stderr
new file mode 100644
index 0000000000..2ec206d665
--- /dev/null
+++ b/third_party/rust/paste/tests/ui/no-env-var.stderr
@@ -0,0 +1,5 @@
+error: no such env var
+ --> $DIR/no-env-var.rs:2:17
+ |
+2 | fn [<a env!("PASTE_UNKNOWN") b>]() {}
+ | ^^^^^^^^^^^^^^^
diff --git a/third_party/rust/paste/tests/ui/unexpected-modifier.rs b/third_party/rust/paste/tests/ui/unexpected-modifier.rs
new file mode 100644
index 0000000000..00a1e99c6d
--- /dev/null
+++ b/third_party/rust/paste/tests/ui/unexpected-modifier.rs
@@ -0,0 +1,5 @@
+paste::item! {
+ fn [<:lower x>]() {}
+}
+
+fn main() {}
diff --git a/third_party/rust/paste/tests/ui/unexpected-modifier.stderr b/third_party/rust/paste/tests/ui/unexpected-modifier.stderr
new file mode 100644
index 0000000000..4a518b8ea8
--- /dev/null
+++ b/third_party/rust/paste/tests/ui/unexpected-modifier.stderr
@@ -0,0 +1,5 @@
+error: unexpected modifier
+ --> $DIR/unexpected-modifier.rs:2:10
+ |
+2 | fn [<:lower x>]() {}
+ | ^^^^^^
diff --git a/third_party/rust/paste/tests/ui/unsupported-modifier.rs b/third_party/rust/paste/tests/ui/unsupported-modifier.rs
new file mode 100644
index 0000000000..5ab049fbb1
--- /dev/null
+++ b/third_party/rust/paste/tests/ui/unsupported-modifier.rs
@@ -0,0 +1,5 @@
+paste::item! {
+ fn [<a:pillow>]() {}
+}
+
+fn main() {}
diff --git a/third_party/rust/paste/tests/ui/unsupported-modifier.stderr b/third_party/rust/paste/tests/ui/unsupported-modifier.stderr
new file mode 100644
index 0000000000..ffbc742a29
--- /dev/null
+++ b/third_party/rust/paste/tests/ui/unsupported-modifier.stderr
@@ -0,0 +1,5 @@
+error: unsupported modifier
+ --> $DIR/unsupported-modifier.rs:2:11
+ |
+2 | fn [<a:pillow>]() {}
+ | ^^^^^^^