summaryrefslogtreecommitdiffstats
path: root/third_party/rust/plane-split/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/plane-split/Cargo.toml')
-rw-r--r--third_party/rust/plane-split/Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/third_party/rust/plane-split/Cargo.toml b/third_party/rust/plane-split/Cargo.toml
new file mode 100644
index 0000000000..102ec7a434
--- /dev/null
+++ b/third_party/rust/plane-split/Cargo.toml
@@ -0,0 +1,34 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "plane-split"
+version = "0.17.1"
+authors = ["Dzmitry Malyshau <kvark@mozilla.com>"]
+description = "Plane splitting"
+documentation = "https://docs.rs/plane-split"
+keywords = ["geometry", "math"]
+license = "MPL-2.0"
+repository = "https://github.com/servo/plane-split"
+[dependencies.binary-space-partition]
+version = "0.1.2"
+
+[dependencies.euclid]
+version = "0.22"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.num-traits]
+version = "0.2"
+default-features = false