summaryrefslogtreecommitdiffstats
path: root/third_party/rust/png/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/png/Cargo.toml')
-rw-r--r--third_party/rust/png/Cargo.toml56
1 files changed, 56 insertions, 0 deletions
diff --git a/third_party/rust/png/Cargo.toml b/third_party/rust/png/Cargo.toml
new file mode 100644
index 0000000000..2e57fab7fe
--- /dev/null
+++ b/third_party/rust/png/Cargo.toml
@@ -0,0 +1,56 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "png"
+version = "0.15.3"
+authors = ["nwin <nwin@users.noreply.github.com>"]
+exclude = ["tests/*"]
+description = "PNG decoding and encoding library in pure Rust"
+categories = ["multimedia::images"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/image-rs/image-png.git"
+[dependencies.bitflags]
+version = "1.0"
+
+[dependencies.crc32fast]
+version = "1.2.0"
+
+[dependencies.deflate]
+version = "0.7.12"
+optional = true
+
+[dependencies.inflate]
+version = "0.4.2"
+[dev-dependencies.getopts]
+version = "0.2.14"
+
+[dev-dependencies.glium]
+version = "0.24"
+features = ["glutin"]
+default-features = false
+
+[dev-dependencies.glob]
+version = "0.3"
+
+[dev-dependencies.rand]
+version = "0.7.0"
+
+[dev-dependencies.term]
+version = "0.6.1"
+
+[features]
+benchmarks = []
+default = ["png-encoding"]
+png-encoding = ["deflate"]
+unstable = []