summaryrefslogtreecommitdiffstats
path: root/third_party/rust/rand_rccrypto/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/rand_rccrypto/Cargo.toml')
-rw-r--r--third_party/rust/rand_rccrypto/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/third_party/rust/rand_rccrypto/Cargo.toml b/third_party/rust/rand_rccrypto/Cargo.toml
new file mode 100644
index 0000000000..100f140bf8
--- /dev/null
+++ b/third_party/rust/rand_rccrypto/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "rand_rccrypto"
+version = "0.1.0"
+authors = ["Edouard Oger <eoger@fastmail.com>"]
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+crate-type = ["lib"]
+
+[dependencies]
+rc_crypto = { path = "../rc_crypto" }
+# We do not need the rand default features as we provide
+# our own Rng implementation backed by rc_crypto.
+rand = { version = "0.7", default-features = false, features = ["std"] }
+rand_core = "0.5"