summaryrefslogtreecommitdiffstats
path: root/third_party/rust/serde/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/serde/Cargo.toml')
-rw-r--r--third_party/rust/serde/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/third_party/rust/serde/Cargo.toml b/third_party/rust/serde/Cargo.toml
new file mode 100644
index 0000000000..4e6fa348f2
--- /dev/null
+++ b/third_party/rust/serde/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "serde"
+version = "1.0.116"
+authors = ["Erick Tryzelaar <erick.tryzelaar@gmail.com>", "David Tolnay <dtolnay@gmail.com>"]
+build = "build.rs"
+include = ["build.rs", "src/**/*.rs", "crates-io.md", "README.md", "LICENSE-APACHE", "LICENSE-MIT"]
+description = "A generic serialization/deserialization framework"
+homepage = "https://serde.rs"
+documentation = "https://docs.serde.rs/serde/"
+readme = "crates-io.md"
+keywords = ["serde", "serialization", "no_std"]
+categories = ["encoding"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/serde-rs/serde"
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[package.metadata.playground]
+features = ["derive", "rc"]
+[dependencies.serde_derive]
+version = "=1.0.116"
+optional = true
+[dev-dependencies.serde_derive]
+version = "1.0"
+
+[features]
+alloc = []
+default = ["std"]
+derive = ["serde_derive"]
+rc = []
+std = []
+unstable = []