summaryrefslogtreecommitdiffstats
path: root/third_party/rust/smallvec/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/smallvec/Cargo.toml')
-rw-r--r--third_party/rust/smallvec/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/third_party/rust/smallvec/Cargo.toml b/third_party/rust/smallvec/Cargo.toml
new file mode 100644
index 0000000000..b8aab8b817
--- /dev/null
+++ b/third_party/rust/smallvec/Cargo.toml
@@ -0,0 +1,37 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "smallvec"
+version = "1.5.1"
+authors = ["The Servo Project Developers"]
+description = "'Small vector' optimization: store up to a small number of items on the stack"
+documentation = "https://docs.rs/smallvec/"
+readme = "README.md"
+keywords = ["small", "vec", "vector", "stack", "no_std"]
+categories = ["data-structures"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/servo/rust-smallvec"
+[dependencies.serde]
+version = "1"
+optional = true
+default-features = false
+[dev-dependencies.bincode]
+version = "1.0.1"
+
+[features]
+const_generics = []
+may_dangle = []
+specialization = []
+union = []
+write = []