summaryrefslogtreecommitdiffstats
path: root/third_party/rust/storage-map
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/storage-map')
-rw-r--r--third_party/rust/storage-map/.cargo-checksum.json1
-rw-r--r--third_party/rust/storage-map/Cargo.toml27
-rw-r--r--third_party/rust/storage-map/LICENSE201
-rw-r--r--third_party/rust/storage-map/README.md2
-rw-r--r--third_party/rust/storage-map/rustfmt.toml0
-rw-r--r--third_party/rust/storage-map/src/lib.rs173
-rw-r--r--third_party/rust/storage-map/tests/ten.rs41
7 files changed, 445 insertions, 0 deletions
diff --git a/third_party/rust/storage-map/.cargo-checksum.json b/third_party/rust/storage-map/.cargo-checksum.json
new file mode 100644
index 0000000000..9e4721c939
--- /dev/null
+++ b/third_party/rust/storage-map/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"85bf5d8b5ab8ea2ba48dbd4523edb207c6462f342cd14ebb9a18ab94120a8c34","LICENSE":"c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4","README.md":"3c9074177c6dfe47137f5709f6d7590d2c10c07df505bb8b6a0e61d0cb6f12f6","rustfmt.toml":"e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855","src/lib.rs":"087d619e4ef4580ffd29ce8ca31b162ec93a9d148f3c32b880f3eba140853243","tests/ten.rs":"ee9028a5a5da0554014855cefb3a09ff6eedf4ca2f82dcc9332c9c13e5639b57"},"package":"418bb14643aa55a7841d5303f72cf512cfb323b8cc221d51580500a1ca75206c"} \ No newline at end of file
diff --git a/third_party/rust/storage-map/Cargo.toml b/third_party/rust/storage-map/Cargo.toml
new file mode 100644
index 0000000000..61439a79bc
--- /dev/null
+++ b/third_party/rust/storage-map/Cargo.toml
@@ -0,0 +1,27 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "storage-map"
+version = "0.3.0"
+authors = ["Dzmitry Malyshau <kvarkus@gmail.com>"]
+description = "Concurrent append-only map storage"
+homepage = "https://github.com/kvark/storage-map"
+documentation = "https://docs.rs/crate/storage-map"
+keywords = ["hashmap", "map", "concurrent", "lock"]
+license = "Apache-2.0"
+repository = "https://github.com/kvark/storage-map"
+[dependencies.lock_api]
+version = "0.4"
+[dev-dependencies.parking_lot]
+version = "0.11"
diff --git a/third_party/rust/storage-map/LICENSE b/third_party/rust/storage-map/LICENSE
new file mode 100644
index 0000000000..261eeb9e9f
--- /dev/null
+++ b/third_party/rust/storage-map/LICENSE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+ 6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+ END OF TERMS AND CONDITIONS
+
+ APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+ Copyright [yyyy] [name of copyright owner]
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
diff --git a/third_party/rust/storage-map/README.md b/third_party/rust/storage-map/README.md
new file mode 100644
index 0000000000..3b25e80188
--- /dev/null
+++ b/third_party/rust/storage-map/README.md
@@ -0,0 +1,2 @@
+# storage-map
+Concurrent append-only storage map in Rust
diff --git a/third_party/rust/storage-map/rustfmt.toml b/third_party/rust/storage-map/rustfmt.toml
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/third_party/rust/storage-map/rustfmt.toml
diff --git a/third_party/rust/storage-map/src/lib.rs b/third_party/rust/storage-map/src/lib.rs
new file mode 100644
index 0000000000..40dcb276c8
--- /dev/null
+++ b/third_party/rust/storage-map/src/lib.rs
@@ -0,0 +1,173 @@
+use lock_api::RawRwLock;
+use std::{cell::UnsafeCell, collections::hash_map::HashMap, fmt, hash, ops};
+
+/// `StorageMap` is a wrapper around `HashMap` that allows efficient concurrent
+/// access for the use case when only rarely the missing elements need to be created.
+pub struct StorageMap<L, M> {
+ lock: L,
+ map: UnsafeCell<M>,
+}
+
+unsafe impl<L: Send, M> Send for StorageMap<L, M> {}
+unsafe impl<L: Sync, M> Sync for StorageMap<L, M> {}
+
+impl<L: RawRwLock, M: Default> Default for StorageMap<L, M> {
+ fn default() -> Self {
+ StorageMap {
+ lock: L::INIT,
+ map: UnsafeCell::new(M::default()),
+ }
+ }
+}
+
+impl<L, M: fmt::Debug> fmt::Debug for StorageMap<L, M> {
+ fn fmt(&self, formatter: &mut fmt::Formatter) -> fmt::Result {
+ self.map.get().fmt(formatter)
+ }
+}
+
+/// An element guard that releases the lock when dropped.
+pub struct StorageMapGuard<'a, L: 'a + RawRwLock, V: 'a> {
+ lock: &'a L,
+ value: &'a V,
+ exclusive: bool,
+}
+
+impl<'a, L: RawRwLock, V> ops::Deref for StorageMapGuard<'a, L, V> {
+ type Target = V;
+ fn deref(&self) -> &V {
+ self.value
+ }
+}
+
+impl<'a, L: RawRwLock, V> Drop for StorageMapGuard<'a, L, V> {
+ fn drop(&mut self) {
+ unsafe {
+ if self.exclusive {
+ self.lock.unlock_exclusive();
+ } else {
+ self.lock.unlock_shared();
+ }
+ }
+ }
+}
+
+pub struct WholeMapWriteGuard<'a, L: 'a + RawRwLock, M: 'a> {
+ lock: &'a L,
+ map: &'a mut M,
+}
+
+impl<'a, L: RawRwLock, M> ops::Deref for WholeMapWriteGuard<'a, L, M> {
+ type Target = M;
+ fn deref(&self) -> &M {
+ self.map
+ }
+}
+
+impl<'a, L: RawRwLock, M> ops::DerefMut for WholeMapWriteGuard<'a, L, M> {
+ fn deref_mut(&mut self) -> &mut M {
+ self.map
+ }
+}
+
+impl<'a, L: RawRwLock, V> Drop for WholeMapWriteGuard<'a, L, V> {
+ fn drop(&mut self) {
+ unsafe {
+ self.lock.unlock_exclusive();
+ }
+ }
+}
+
+/// Result of preparing a particular key.
+pub enum PrepareResult {
+ /// Nothing is created, the key/value pair is already there.
+ AlreadyExists,
+ /// Key was not found, but value creation failed.
+ UnableToCreate,
+ /// Key was not found, but now the value has been created and inserted.
+ Created,
+}
+
+impl<L, K, V, S> StorageMap<L, HashMap<K, V, S>>
+where
+ L: RawRwLock,
+ K: Clone + Eq + hash::Hash,
+ S: hash::BuildHasher,
+{
+ /// Create a new storage map with the given hasher.
+ pub fn with_hasher(hash_builder: S) -> Self {
+ StorageMap {
+ lock: L::INIT,
+ map: UnsafeCell::new(HashMap::with_hasher(hash_builder)),
+ }
+ }
+
+ /// Get a value associated with the key. The method assumes that more often then not
+ /// the value is already there. If it's not - the closure will be called to create one.
+ /// This closure is expected to always produce the same value given the same key.
+ pub fn get_or_create_with<'a, F: FnOnce() -> V>(
+ &'a self,
+ key: &K,
+ create_fn: F,
+ ) -> StorageMapGuard<'a, L, V> {
+ self.lock.lock_shared();
+ // try mapping for reading first
+ let map = unsafe { &*self.map.get() };
+ if let Some(value) = map.get(key) {
+ return StorageMapGuard {
+ lock: &self.lock,
+ value,
+ exclusive: false,
+ };
+ }
+ unsafe {
+ self.lock.unlock_shared();
+ }
+ // now actually lock for writes
+ let value = create_fn();
+ self.lock.lock_exclusive();
+ let map = unsafe { &mut *self.map.get() };
+ StorageMapGuard {
+ lock: &self.lock,
+ value: &*map.entry(key.clone()).or_insert(value),
+ exclusive: true,
+ }
+ }
+
+ /// Make sure the given key is in the map, as a way to warm up
+ /// future run-time access to the map at the initialization stage.
+ pub fn prepare_maybe<F: FnOnce() -> Option<V>>(&self, key: &K, create_fn: F) -> PrepareResult {
+ self.lock.lock_shared();
+ // try mapping for reading first
+ let map = unsafe { &*self.map.get() };
+ let has = map.contains_key(key);
+ unsafe {
+ self.lock.unlock_shared();
+ }
+ if has {
+ return PrepareResult::AlreadyExists;
+ }
+ // try creating a new value
+ let value = match create_fn() {
+ Some(value) => value,
+ None => return PrepareResult::UnableToCreate,
+ };
+ // now actually lock for writes
+ self.lock.lock_exclusive();
+ let map = unsafe { &mut *self.map.get() };
+ map.insert(key.clone(), value);
+ unsafe {
+ self.lock.unlock_exclusive();
+ }
+ PrepareResult::Created
+ }
+
+ /// Lock the whole map for writing.
+ pub fn whole_write(&self) -> WholeMapWriteGuard<L, HashMap<K, V, S>> {
+ self.lock.lock_exclusive();
+ WholeMapWriteGuard {
+ lock: &self.lock,
+ map: unsafe { &mut *self.map.get() },
+ }
+ }
+}
diff --git a/third_party/rust/storage-map/tests/ten.rs b/third_party/rust/storage-map/tests/ten.rs
new file mode 100644
index 0000000000..df3e183cbe
--- /dev/null
+++ b/third_party/rust/storage-map/tests/ten.rs
@@ -0,0 +1,41 @@
+use std::{
+ collections::hash_map::{HashMap, RandomState},
+ sync::Arc,
+ thread, time,
+};
+
+#[test]
+fn fill_ten() {
+ type Map = HashMap<u8, String, RandomState>;
+ let s = RandomState::new();
+ let map = storage_map::StorageMap::<parking_lot::RawRwLock, Map>::with_hasher(s);
+ let arc = Arc::new(map);
+ let join_handles = (0..10000usize)
+ .map(|i| {
+ let arc = Arc::clone(&arc);
+ let key = (i % 10) as u8;
+ thread::spawn(move || {
+ arc.get_or_create_with(&key, || {
+ thread::sleep(time::Duration::new(0, 100));
+ format!("{}", i)
+ });
+ })
+ })
+ .collect::<Vec<_>>();
+ for handle in join_handles {
+ let _ = handle.join();
+ }
+}
+
+#[test]
+fn whole_write() {
+ type Map = HashMap<u8, String, RandomState>;
+ let map =
+ storage_map::StorageMap::<parking_lot::RawRwLock, Map>::with_hasher(RandomState::new());
+ map.get_or_create_with(&3, || "three".to_owned());
+ map.get_or_create_with(&5, || "five".to_owned());
+ let mut guard = map.whole_write();
+ for (_key, _value) in guard.drain() {
+ //nothing
+ }
+}