summaryrefslogtreecommitdiffstats
path: root/third_party/rust/uuid/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/uuid/Cargo.toml')
-rw-r--r--third_party/rust/uuid/Cargo.toml92
1 files changed, 92 insertions, 0 deletions
diff --git a/third_party/rust/uuid/Cargo.toml b/third_party/rust/uuid/Cargo.toml
new file mode 100644
index 0000000000..dd6684eebf
--- /dev/null
+++ b/third_party/rust/uuid/Cargo.toml
@@ -0,0 +1,92 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "uuid"
+version = "0.8.1"
+authors = ["Ashley Mannix<ashleymannix@live.com.au>", "Christopher Armstrong", "Dylan DPC<dylan.dpc@gmail.com>", "Hunar Roop Kahlon<hunar.roop@gmail.com>"]
+exclude = [".github/**", ".travis.yml", "appveyor.yml", "bors.toml"]
+description = "A library to generate and parse UUIDs."
+homepage = "https://github.com/uuid-rs/uuid"
+documentation = "https://docs.rs/uuid"
+readme = "README.md"
+keywords = ["guid", "unique", "uuid"]
+categories = ["data-structures", "no-std", "parser-implementations", "wasm"]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/uuid-rs/uuid"
+[package.metadata.docs.rs]
+default-target = "x86_64-pc-windows-msvc"
+features = ["guid", "serde", "slog", "v1", "v3", "v4", "v5"]
+
+[package.metadata.playground]
+features = ["serde", "v1", "v3", "v4", "v5"]
+[dependencies.md5]
+version = "0.6"
+optional = true
+
+[dependencies.rand]
+version = "0.7"
+optional = true
+
+[dependencies.serde]
+version = "1.0.56"
+features = ["serde_derive"]
+optional = true
+default-features = false
+
+[dependencies.sha1]
+version = "0.6"
+optional = true
+
+[dependencies.slog]
+version = "2"
+optional = true
+[dev-dependencies.bincode]
+version = "1.0"
+
+[dev-dependencies.serde_derive]
+version = "1.0.79"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.serde_test]
+version = "1.0.56"
+
+[features]
+default = ["std"]
+guid = ["winapi"]
+std = []
+stdweb = ["rand/stdweb"]
+v1 = []
+v3 = ["md5"]
+v4 = ["rand"]
+v5 = ["sha1"]
+wasm-bindgen = ["rand/wasm-bindgen"]
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+optional = true
+[badges.appveyor]
+repository = "uuid-rs/uuid"
+
+[badges.is-it-maintained-issue-resolution]
+repository = "uuid-rs/uuid"
+
+[badges.is-it-maintained-open-issues]
+repository = "uuid-rs/uuid"
+
+[badges.maintenance]
+status = "actively-developed"
+
+[badges.travis-ci]
+repository = "uuid-rs/uuid"