summaryrefslogtreecommitdiffstats
path: root/third_party/rust/viaduct/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/viaduct/Cargo.toml')
-rw-r--r--third_party/rust/viaduct/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/third_party/rust/viaduct/Cargo.toml b/third_party/rust/viaduct/Cargo.toml
new file mode 100644
index 0000000000..82560c8df2
--- /dev/null
+++ b/third_party/rust/viaduct/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "viaduct"
+version = "0.1.0"
+authors = ["Thom Chiovoloni <tchiovoloni@mozilla.com>"]
+edition = "2018"
+license = "MPL-2.0"
+exclude = ["/android", "/ios"]
+
+[lib]
+crate-type = ["lib"]
+
+[features]
+default = []
+
+[dependencies]
+url = "2.1"
+log = "0.4"
+serde = "1"
+serde_json = "1"
+once_cell = "1.4"
+prost = "0.6"
+prost-derive = "0.6"
+ffi-support = "0.4"
+thiserror = "1.0"