summaryrefslogtreecommitdiffstats
path: root/third_party/rust/winreg/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/winreg/Cargo.toml')
-rw-r--r--third_party/rust/winreg/Cargo.toml61
1 files changed, 61 insertions, 0 deletions
diff --git a/third_party/rust/winreg/Cargo.toml b/third_party/rust/winreg/Cargo.toml
new file mode 100644
index 0000000000..c5fd651116
--- /dev/null
+++ b/third_party/rust/winreg/Cargo.toml
@@ -0,0 +1,61 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "winreg"
+version = "0.5.1"
+authors = ["Igor Shaula <gentoo90@gmail.com>"]
+description = "Rust bindings to MS Windows Registry API"
+documentation = "https://gentoo90.github.io/winreg-rs/v0.5.1/winreg"
+readme = "README.md"
+keywords = ["Windows", "WinSDK", "Registry"]
+categories = ["api-bindings", "os::windows-apis"]
+license = "MIT"
+repository = "https://github.com/gentoo90/winreg-rs"
+
+[[example]]
+name = "basic_usage"
+
+[[example]]
+name = "enum"
+
+[[example]]
+name = "transactions"
+required-features = ["transactions"]
+
+[[example]]
+name = "serialization"
+required-features = ["serialization-serde"]
+
+[[example]]
+name = "installed_apps"
+required-features = ["serialization-serde"]
+[dependencies.clippy]
+version = "^0"
+optional = true
+
+[dependencies.serde]
+version = "1"
+optional = true
+
+[dependencies.winapi]
+version = "0.3"
+features = ["minwindef", "winerror", "winnt", "winreg", "handleapi"]
+[dev-dependencies.rand]
+version = "0.3"
+
+[dev-dependencies.serde_derive]
+version = "1"
+
+[features]
+serialization-serde = ["transactions", "serde"]
+transactions = ["winapi/ktmw32"]