summaryrefslogtreecommitdiffstats
path: root/pam_gdm/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:30:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:30:14 +0000
commitf38bddc70a6ec7c1ab26d9a8b06eed25d618ae22 (patch)
tree6437d0de9ba7fb9b0933a7c0eaa610a404d79e4e /pam_gdm/meson.build
parentInitial commit. (diff)
downloadgdm3-f38bddc70a6ec7c1ab26d9a8b06eed25d618ae22.tar.xz
gdm3-f38bddc70a6ec7c1ab26d9a8b06eed25d618ae22.zip
Adding upstream version 3.38.2.1.upstream/3.38.2.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pam_gdm/meson.build')
-rw-r--r--pam_gdm/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/pam_gdm/meson.build b/pam_gdm/meson.build
new file mode 100644
index 0000000..f47d8e6
--- /dev/null
+++ b/pam_gdm/meson.build
@@ -0,0 +1,16 @@
+pam_gdm_deps = [
+ libpam_dep,
+]
+
+if keyutils_dep.found()
+ pam_gdm_deps += keyutils_dep
+endif
+
+pam_gdm = library('pam_gdm',
+ 'pam_gdm.c',
+ dependencies: pam_gdm_deps,
+ include_directories: config_h_dir,
+ name_prefix: '',
+ install: true,
+ install_dir: pam_mod_dir,
+)