summaryrefslogtreecommitdiffstats
path: root/debian/changelog.upstream.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:49:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:49:37 +0000
commit43fb36463ac1df398f62397b36e570aa9af94d91 (patch)
treea69979c10da617a3df2d55ecde5503f1c0ec1126 /debian/changelog.upstream.sh
parentAdding upstream version 1:2.30.2. (diff)
downloadgit-debian.tar.xz
git-debian.zip
Adding debian version 1:2.30.2-1+deb11u2.debian/1%2.30.2-1+deb11u2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/changelog.upstream.sh')
-rwxr-xr-xdebian/changelog.upstream.sh16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/changelog.upstream.sh b/debian/changelog.upstream.sh
new file mode 100755
index 0000000..3441546
--- /dev/null
+++ b/debian/changelog.upstream.sh
@@ -0,0 +1,16 @@
+#!/bin/sh
+set -e
+: >debian/changelog.upstream
+exec <debian/versions.upstream
+read old
+while read new; do
+ exec >debian/changelog.upstream."$new"
+ echo "Version $new; changes since $old:"
+ echo "Version $new; changes since $old:" |tr '[:print:]' -
+ echo
+ git shortlog --no-merges "$old".."$new"
+ echo
+ cat debian/changelog.upstream
+ mv debian/changelog.upstream."$new" debian/changelog.upstream
+ old="$new"
+done