summaryrefslogtreecommitdiffstats
path: root/subprojects/libhandy/.editorconfig
diff options
context:
space:
mode:
Diffstat (limited to 'subprojects/libhandy/.editorconfig')
-rw-r--r--subprojects/libhandy/.editorconfig38
1 files changed, 38 insertions, 0 deletions
diff --git a/subprojects/libhandy/.editorconfig b/subprojects/libhandy/.editorconfig
new file mode 100644
index 0000000..70827f6
--- /dev/null
+++ b/subprojects/libhandy/.editorconfig
@@ -0,0 +1,38 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+
+[meson.build]
+indent_size = 2
+tab_size = 2
+indent_style = space
+
+[*.{c,h,h.in}]
+indent_size = 2
+tab_size = 2
+indent_style = space
+max_line_length = 80
+
+[*.css]
+indent_size = 2
+tab_size = 2
+indent_style = space
+
+[*.xml]
+indent_size = 2
+tab_size = 2
+indent_style = space
+
+[*.json]
+indent_size = 2
+tab_size = 2
+indent_style = space
+
+[NEWS]
+indent_size = 2
+tab_size = 2
+indent_style = space
+max_line_length = 72