summaryrefslogtreecommitdiffstats
path: root/plugins/common/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:51:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:51:55 +0000
commit86b7f1a83d7db9c912f32b29c32e1124c0a6454d (patch)
tree42a7ff7c6885e99e0669d07b104df11b2bf387b6 /plugins/common/meson.build
parentInitial commit. (diff)
downloadgnome-settings-daemon-upstream.tar.xz
gnome-settings-daemon-upstream.zip
Adding upstream version 3.38.2.upstream/3.38.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'plugins/common/meson.build')
-rw-r--r--plugins/common/meson.build43
1 files changed, 43 insertions, 0 deletions
diff --git a/plugins/common/meson.build b/plugins/common/meson.build
new file mode 100644
index 0000000..2f18c2c
--- /dev/null
+++ b/plugins/common/meson.build
@@ -0,0 +1,43 @@
+common_inc = include_directories('.')
+
+sources = files(
+ 'gsd-input-helper.c',
+ 'gsd-settings-migrate.c',
+ 'gsd-shell-helper.c'
+)
+
+resource_data = files('gtk.css')
+
+sources += gnome.compile_resources(
+ 'gsd-resources',
+ 'gsd.gresources.xml',
+ c_name: 'gsd',
+ dependencies: resource_data
+)
+
+deps = plugins_deps + [
+ gnome_desktop_dep,
+ gtk_x11_dep,
+ x11_dep,
+ dependency('kbproto'),
+ dependency('xi')
+]
+
+ldflags = []
+if host_is_darwin
+ ldflags += ['-Wl,-bundle_loader,@0@'.format(join_paths(), meson.build_root(), meson.project_name(), meson.project_name())]
+endif
+
+libcommon = static_library(
+ plugin_name,
+ sources: sources,
+ include_directories: [top_inc, data_inc],
+ dependencies: deps,
+ c_args: cflags,
+ link_args: ldflags
+)
+
+libcommon_dep = declare_dependency(
+ include_directories: common_inc,
+ link_with: libcommon
+)