summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:59:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:59:22 +0000
commit97410c6b8aa025d5c2fa1cd7b63e235c30638370 (patch)
tree62bbfd675f00acd422f622bcb42e301ec11c686e /debian/rules
parentAdding upstream version 0.4.5. (diff)
downloadgnome-shell-extension-impatience-97410c6b8aa025d5c2fa1cd7b63e235c30638370.tar.xz
gnome-shell-extension-impatience-97410c6b8aa025d5c2fa1cd7b63e235c30638370.zip
Adding debian version 0.4.5-4.debian/0.4.5-4debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f8bd3bf
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+# We don't need to build a zip archive, and skipping it
+# reduces the need for zip as a build-dep.
+# We do need to compile new plugin schemas though since the
+# schema path is hardcoded for this plugin.
+override_dh_auto_build:
+ glib-compile-schemas --strict --targetdir=impatience/schemas/ impatience/schemas
+