summaryrefslogtreecommitdiffstats
path: root/subprojects/extensions-tool/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:07:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:07:22 +0000
commitf9d480cfe50ca1d7a0f0b5a2b8bb9932962bfbe7 (patch)
treece9e8db2d4e8799780fa72ae8f1953039373e2ee /subprojects/extensions-tool/meson.build
parentInitial commit. (diff)
downloadgnome-shell-f9d480cfe50ca1d7a0f0b5a2b8bb9932962bfbe7.tar.xz
gnome-shell-f9d480cfe50ca1d7a0f0b5a2b8bb9932962bfbe7.zip
Adding upstream version 3.38.6.upstream/3.38.6upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'subprojects/extensions-tool/meson.build')
-rw-r--r--subprojects/extensions-tool/meson.build80
1 files changed, 80 insertions, 0 deletions
diff --git a/subprojects/extensions-tool/meson.build b/subprojects/extensions-tool/meson.build
new file mode 100644
index 0000000..1e57f23
--- /dev/null
+++ b/subprojects/extensions-tool/meson.build
@@ -0,0 +1,80 @@
+project('gnome-extensions-tool', 'c',
+ version: '3.38.6',
+ meson_version: '>= 0.53.0',
+ license: 'GPLv2+'
+)
+
+gio_req = '>= 2.56.0'
+
+gnome = import('gnome')
+i18n = import('i18n')
+
+if meson.is_subproject()
+ package_name = get_option('package_name')
+ assert(package_name != '',
+ 'package_name must be specified for subproject builds')
+else
+ package_name = meson.project_name()
+endif
+
+package_version = meson.project_version()
+prefix = get_option('prefix')
+
+bindir = join_paths(prefix, get_option('bindir'))
+datadir = join_paths(prefix, get_option('datadir'))
+mandir = join_paths(prefix, get_option('mandir'))
+
+localedir = join_paths(datadir, 'locale')
+
+gio_dep = dependency('gio-2.0', version: gio_req)
+gio_unix_dep = dependency('gio-unix-2.0', version: gio_req)
+autoar_dep = dependency('gnome-autoar-0')
+json_dep = dependency('json-glib-1.0')
+
+cc = meson.get_compiler('c')
+
+bash_completion = dependency('bash-completion', required: get_option('bash_completion'))
+
+po_dir = meson.source_root() + '/po'
+
+subdir('src')
+
+if bash_completion.found()
+ install_data('completion/bash/gnome-extensions',
+ install_dir: bash_completion.get_pkgconfig_variable('completionsdir', define_variable: ['datadir', datadir])
+ )
+endif
+
+if get_option('man')
+ a2x = find_program('a2x')
+
+ subdir('man')
+endif
+
+if not meson.is_subproject()
+ subdir('po')
+
+ summary_dirs = {
+ 'prefix': get_option('prefix'),
+ 'bindir': get_option('bindir'),
+ 'datadir': get_option('datadir'),
+ }
+
+ if get_option('man')
+ summary_dirs += { 'mandir': get_option('mandir') }
+ endif
+
+ summary_build = {
+ 'buildtype': get_option('buildtype'),
+ 'debug': get_option('debug'),
+ }
+
+ summary_options = {
+ 'man': get_option('man'),
+ 'bash_completion': bash_completion.found(),
+ }
+
+ summary(summary_dirs, section: 'Directories')
+ summary(summary_build, section: 'Build Configuration')
+ summary(summary_options, section: 'Build Options')
+endif