summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1a9056c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
+
+%:
+ dh $@ --with bash_completion
+
+ifeq ($(DEB_HOST_ARCH_OS),linux)
+CONFFLAGS = \
+ -Dnetworkmanager=true \
+ -Dsystemd=true
+endif
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --libdir=/usr/lib \
+ -Dbash_completion=true \
+ $(CONFFLAGS)
+
+override_dh_makeshlibs:
+ dh_makeshlibs -X/usr/lib/gnome-shell/
+
+override_dh_shlibdeps:
+ # gnome-shell uses mutters private mutter-clutter-1.0.so etc.
+ dh_shlibdeps -l"usr/lib/$(DEB_HOST_MULTIARCH)/mutter"
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ dbus-run-session xvfb-run -a dh_auto_test
+endif