summaryrefslogtreecommitdiffstats
path: root/plugins/fedora-langpacks
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/fedora-langpacks')
-rw-r--r--plugins/fedora-langpacks/gs-plugin-fedora-langpacks.c101
-rw-r--r--plugins/fedora-langpacks/gs-self-test.c88
-rw-r--r--plugins/fedora-langpacks/meson.build40
3 files changed, 229 insertions, 0 deletions
diff --git a/plugins/fedora-langpacks/gs-plugin-fedora-langpacks.c b/plugins/fedora-langpacks/gs-plugin-fedora-langpacks.c
new file mode 100644
index 0000000..ea673b1
--- /dev/null
+++ b/plugins/fedora-langpacks/gs-plugin-fedora-langpacks.c
@@ -0,0 +1,101 @@
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: t; c-basic-offset: 8 -*-
+ * vi:set noexpandtab tabstop=8 shiftwidth=8:
+ *
+ * Copyright (C) 2019 Sundeep Anand <suanand@redhat.com>
+ *
+ * SPDX-License-Identifier: GPL-2.0+
+ *
+ * This plugin does following..
+ * 1. locates the active locale, say, xx
+ * 2. identifies related langpacks-xx
+ * 3. tries to add langpack-xx in app list
+ * 4. logs install information; not to try again
+ */
+
+#include <gnome-software.h>
+
+struct GsPluginData {
+ GHashTable *locale_langpack_map;
+};
+
+void
+gs_plugin_initialize (GsPlugin *plugin)
+{
+ GsPluginData *priv = gs_plugin_alloc_data (plugin, sizeof(GsPluginData));
+
+ /* this plugin should be fedora specific */
+ if (!gs_plugin_check_distro_id (plugin, "fedora")) {
+ gs_plugin_set_enabled (plugin, FALSE);
+ return;
+ }
+
+ gs_plugin_add_rule (plugin, GS_PLUGIN_RULE_RUN_AFTER, "appstream");
+
+ /*
+ * A few language code may have more than one language packs.
+ * Example: en {en_GB}, pt {pt_BR}, zh {zh_CN, zh_TW}
+ */
+ priv->locale_langpack_map = g_hash_table_new (g_str_hash, g_str_equal);
+ g_hash_table_insert (priv->locale_langpack_map, "en_GB", "langpacks-en_GB");
+ g_hash_table_insert (priv->locale_langpack_map, "pt_BR", "langpacks-pt_BR");
+ g_hash_table_insert (priv->locale_langpack_map, "zh_CN", "langpacks-zh_CN");
+ g_hash_table_insert (priv->locale_langpack_map, "zh_TW", "langpacks-zh_TW");
+}
+
+void
+gs_plugin_destroy (GsPlugin *plugin)
+{
+ GsPluginData *priv = gs_plugin_get_data (plugin);
+ if (priv->locale_langpack_map != NULL)
+ g_hash_table_unref (priv->locale_langpack_map);
+}
+
+gboolean
+gs_plugin_add_langpacks (GsPlugin *plugin,
+ GsAppList *list,
+ const gchar *locale,
+ GCancellable *cancellable,
+ GError **error)
+{
+ GsPluginData *priv = gs_plugin_get_data (plugin);
+ const gchar *language_code;
+ g_autofree gchar *cachefn = NULL;
+ g_autofree gchar *langpack_pkgname = NULL;
+ g_auto(GStrv) language_region = NULL;
+
+ if (g_strrstr (locale, "_") != NULL &&
+ !g_hash_table_lookup (priv->locale_langpack_map, locale)) {
+ /*
+ * language_code should be the langpack_source_id
+ * if input language_code is a locale and it doesn't
+ * not found in locale_langpack_map
+ */
+ language_region = g_strsplit (locale, "_", 2);
+ language_code = language_region[0];
+ } else {
+ language_code = locale;
+ }
+
+ /* per-user cache */
+ langpack_pkgname = g_strconcat ("langpacks-", language_code, NULL);
+ cachefn = gs_utils_get_cache_filename ("langpacks", langpack_pkgname,
+ GS_UTILS_CACHE_FLAG_WRITEABLE,
+ error);
+ if (cachefn == NULL)
+ return FALSE;
+ if (!g_file_test (cachefn, G_FILE_TEST_EXISTS)) {
+ g_autoptr(GsApp) app = gs_app_new (NULL);
+ gs_app_set_metadata (app, "GnomeSoftware::Creator", gs_plugin_get_name (plugin));
+ gs_app_set_kind (app, AS_APP_KIND_LOCALIZATION);
+ gs_app_set_bundle_kind (app, AS_BUNDLE_KIND_PACKAGE);
+ gs_app_set_scope (app, AS_APP_SCOPE_SYSTEM);
+ gs_app_add_source (app, langpack_pkgname);
+ gs_app_list_add (list, app);
+
+ /* ensure we do not keep trying to install the langpack */
+ if (!g_file_set_contents (cachefn, language_code, -1, error))
+ return FALSE;
+ }
+
+ return TRUE;
+}
diff --git a/plugins/fedora-langpacks/gs-self-test.c b/plugins/fedora-langpacks/gs-self-test.c
new file mode 100644
index 0000000..ac8c176
--- /dev/null
+++ b/plugins/fedora-langpacks/gs-self-test.c
@@ -0,0 +1,88 @@
+/* -*- Mode: C; tab-width: 8; indent-tabs-mode: t; c-basic-offset: 8 -*-
+ * vi:set noexpandtab tabstop=8 shiftwidth=8:
+ *
+ * Copyright (C) 2019 Richard Hughes <richard@hughsie.com>
+ *
+ * SPDX-License-Identifier: GPL-2.0+
+ */
+
+#include "config.h"
+
+#include <glib/gstdio.h>
+
+#include "gnome-software-private.h"
+
+#include "gs-test.h"
+
+static void
+gs_plugins_fedora_langpacks_func (GsPluginLoader *plugin_loader)
+{
+ g_autofree gchar *cachefn = NULL;
+ g_autoptr(GError) error = NULL;
+ g_autoptr(GsApp) app = NULL;
+ g_autoptr(GsAppList) list = NULL;
+ g_autoptr(GsPluginJob) plugin_job = NULL;
+
+ /* start with a clean slate */
+ cachefn = gs_utils_get_cache_filename ("langpacks", "langpacks-ja",
+ GS_UTILS_CACHE_FLAG_WRITEABLE,
+ &error);
+ g_assert_no_error (error);
+ g_unlink (cachefn);
+
+ /* get langpacks result based on locale */
+ plugin_job = gs_plugin_job_newv (GS_PLUGIN_ACTION_GET_LANGPACKS,
+ "search", "ja_JP",
+ "refine-flags", GS_PLUGIN_REFINE_FLAGS_REQUIRE_ICON,
+ NULL);
+ list = gs_plugin_loader_job_process (plugin_loader, plugin_job, NULL, &error);
+ g_assert_nonnull (list);
+ g_assert_no_error (error);
+
+ /* check if we have just one app in the list */
+ g_assert_cmpint (gs_app_list_length (list), ==, 1);
+
+ /* check app's source and kind */
+ app = gs_app_list_index (list, 0);
+ g_assert_cmpstr (gs_app_get_source_default (app), ==, "langpacks-ja");
+ g_assert_cmpint (gs_app_get_kind (app), ==, AS_APP_KIND_LOCALIZATION);
+}
+
+int
+main (int argc, char **argv)
+{
+ gboolean ret;
+ g_autoptr(GError) error = NULL;
+ g_autoptr(GsPluginLoader) plugin_loader = NULL;
+ const gchar *allowlist[] = {
+ "fedora-langpacks",
+ NULL
+ };
+
+ g_test_init (&argc, &argv,
+#if GLIB_CHECK_VERSION(2, 60, 0)
+ G_TEST_OPTION_ISOLATE_DIRS,
+#endif
+ NULL);
+ g_setenv ("G_MESSAGES_DEBUG", "all", TRUE);
+
+ /* only critical and error are fatal */
+ g_log_set_fatal_mask (NULL, G_LOG_LEVEL_ERROR | G_LOG_LEVEL_CRITICAL);
+
+ /* we can only load this once per process */
+ plugin_loader = gs_plugin_loader_new ();
+ gs_plugin_loader_add_location (plugin_loader, LOCALPLUGINDIR);
+ ret = gs_plugin_loader_setup (plugin_loader,
+ (gchar**) allowlist,
+ NULL,
+ NULL,
+ &error);
+ g_assert_no_error (error);
+ g_assert (ret);
+
+ /* plugin tests go here */
+ g_test_add_data_func ("/gnome-software/plugins/fedora-langpacks",
+ plugin_loader,
+ (GTestDataFunc) gs_plugins_fedora_langpacks_func);
+ return g_test_run ();
+}
diff --git a/plugins/fedora-langpacks/meson.build b/plugins/fedora-langpacks/meson.build
new file mode 100644
index 0000000..cdc3757
--- /dev/null
+++ b/plugins/fedora-langpacks/meson.build
@@ -0,0 +1,40 @@
+cargs = ['-DG_LOG_DOMAIN="GsPluginFedoraLangpacks"']
+
+shared_module(
+ 'gs_plugin_fedora-langpacks',
+ sources : 'gs-plugin-fedora-langpacks.c',
+ include_directories : [
+ include_directories('../..'),
+ include_directories('../../lib'),
+ ],
+ install : true,
+ install_dir: plugin_dir,
+ c_args : cargs,
+ dependencies : plugin_libs,
+ link_with : [
+ libgnomesoftware
+ ]
+)
+
+if get_option('tests')
+ cargs += ['-DLOCALPLUGINDIR="' + meson.current_build_dir() + '"']
+ e = executable(
+ 'gs-self-test-fedora-langpacks',
+ compiled_schemas,
+ sources : [
+ 'gs-self-test.c',
+ ],
+ include_directories : [
+ include_directories('../..'),
+ include_directories('../../lib'),
+ ],
+ dependencies : [
+ plugin_libs,
+ ],
+ link_with : [
+ libgnomesoftware
+ ],
+ c_args : cargs,
+ )
+ test('gs-self-test-fedora-langpacks', e, suite: ['plugins', 'fedora-langpacks'], env: test_env)
+endif