summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:21:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:21:32 +0000
commitf8a786c8f7878517aa695a69322bc9f2c8b92b6a (patch)
tree0cb8f00f8c10625d5d75244ef9dde521d94f8678 /man/Makefile.am
parentInitial commit. (diff)
downloadgnome-terminal-upstream.tar.xz
gnome-terminal-upstream.zip
Adding upstream version 3.38.3.upstream/3.38.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 0000000..ecce224
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,18 @@
+XSLTPROC_FLAGS = \
+ --nonet \
+ --stringparam man.output.quietly 1 \
+ --stringparam funcsynopsis.style ansi \
+ --stringparam man.authors.section.enabled 0 \
+ --stringparam man.copyright.section.enabled 0
+
+.xml.1:
+ $(AM_V_GEN) $(XSLTPROC) $(XSLTPROC_FLAGS) http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+man_MANS = \
+ gnome-terminal.1
+
+xml_files = $(man_MANS:.1=.xml)
+
+EXTRA_DIST = $(xml_files)
+
+CLEANFILES = $(man_MANS)