summaryrefslogtreecommitdiffstats
path: root/share/keys/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'share/keys/CMakeLists.txt')
-rw-r--r--share/keys/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/share/keys/CMakeLists.txt b/share/keys/CMakeLists.txt
new file mode 100644
index 0000000..0d770cd
--- /dev/null
+++ b/share/keys/CMakeLists.txt
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+file(GLOB _FILES "*.xml")
+install(FILES ${_FILES} DESTINATION ${INKSCAPE_SHARE_INSTALL}/keys)
+
+# install a duplicate of inkscape.xml as default.xml
+# default.xml is the default keymap that will be used by inkscape after installation
+# replace this with a keymap of your own to override the Inkscape default shortcuts
+install(FILES inkscape.xml
+ DESTINATION ${INKSCAPE_SHARE_INSTALL}/keys
+ RENAME default.xml)