summaryrefslogtreecommitdiffstats
path: root/src/util/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/CMakeLists.txt')
-rw-r--r--src/util/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/util/CMakeLists.txt b/src/util/CMakeLists.txt
new file mode 100644
index 0000000..4815590
--- /dev/null
+++ b/src/util/CMakeLists.txt
@@ -0,0 +1,40 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+set(util_SRC
+ ege-appear-time-tracker.cpp
+ ege-tags.cpp
+ expression-evaluator.cpp
+ share.cpp
+ units.cpp
+ ziptool.cpp
+
+
+ # -------
+ # Headers
+ const_char_ptr.h
+ copy.h
+ ege-appear-time-tracker.h
+ ege-tags.h
+ enums.h
+ expression-evaluator.h
+ find-if-before.h
+ find-last-if.h
+ fixed_point.h
+ format.h
+ forward-pointer-iterator.h
+ list-container-test.h
+ list-container.h
+ list-copy.h
+ list.h
+ longest-common-suffix.h
+ reference.h
+ reverse-list.h
+ share.h
+ signal-blocker.h
+ ucompose.hpp
+ units.h
+ ziptool.h
+)
+
+add_inkscape_lib(util_LIB "${util_SRC}")
+# add_inkscape_source("${util_SRC}")