summaryrefslogtreecommitdiffstats
path: root/src/widgets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/widgets/CMakeLists.txt')
-rw-r--r--src/widgets/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/src/widgets/CMakeLists.txt b/src/widgets/CMakeLists.txt
new file mode 100644
index 0000000..3ed2a37
--- /dev/null
+++ b/src/widgets/CMakeLists.txt
@@ -0,0 +1,45 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+set(widgets_SRC
+ desktop-widget.cpp
+ ege-paint-def.cpp
+ fill-style.cpp
+ gradient-image.cpp
+ gradient-selector.cpp
+ gradient-vector.cpp
+ ink-action.cpp
+ paint-selector.cpp
+ sp-attribute-widget.cpp
+ sp-color-selector.cpp
+ sp-xmlview-tree.cpp
+ spinbutton-events.cpp
+ spw-utilities.cpp
+ stroke-marker-selector.cpp
+ stroke-style.cpp
+ swatch-selector.cpp
+ toolbox.cpp
+
+ # -------
+ # Headers
+ desktop-widget.h
+ ege-paint-def.h
+ fill-n-stroke-factory.h
+ fill-style.h
+ gradient-image.h
+ gradient-selector.h
+ gradient-vector.h
+ ink-action.h
+ paint-selector.h
+ sp-attribute-widget.h
+ sp-color-selector.h
+ sp-xmlview-tree.h
+ spinbutton-events.h
+ spw-utilities.h
+ stroke-marker-selector.h
+ stroke-style.h
+ swatch-selector.h
+ toolbox.h
+ widget-sizes.h
+)
+
+add_inkscape_source("${widgets_SRC}")