summaryrefslogtreecommitdiffstats
path: root/modules/ta_update/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'modules/ta_update/meson.build')
-rw-r--r--modules/ta_update/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/ta_update/meson.build b/modules/ta_update/meson.build
new file mode 100644
index 0000000..f295cba
--- /dev/null
+++ b/modules/ta_update/meson.build
@@ -0,0 +1,19 @@
+# LUA module: ta_update
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+config_tests += [
+ ['ta_update', files('ta_update.test.lua'), ['snowflake']],
+]
+
+integr_tests += [
+ ['ta_update', meson.current_source_dir() / 'ta_update.test.integr'],
+ ['ta_update.unmanagedkey', meson.current_source_dir() / 'ta_update.unmanagedkey.test.integr'],
+]
+
+lua_mod_src += [
+ files('ta_update.lua'),
+]
+
+install_data(
+ install_dir: modules_dir / 'ta_update',
+)