summaryrefslogtreecommitdiffstats
path: root/avmedia/Library_avmedia.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /avmedia/Library_avmedia.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'avmedia/Library_avmedia.mk')
-rw-r--r--avmedia/Library_avmedia.mk76
1 files changed, 76 insertions, 0 deletions
diff --git a/avmedia/Library_avmedia.mk b/avmedia/Library_avmedia.mk
new file mode 100644
index 000000000..b27b9bae8
--- /dev/null
+++ b/avmedia/Library_avmedia.mk
@@ -0,0 +1,76 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,avmedia))
+
+$(eval $(call gb_Library_set_componentfile,avmedia,avmedia/util/avmedia))
+
+$(eval $(call gb_Library_set_include,avmedia,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/avmedia/inc \
+ -I$(SRCDIR)/avmedia/source/inc \
+))
+
+$(eval $(call gb_Library_set_componentfile,avmedia,avmedia/util/avmedia))
+
+$(eval $(call gb_Library_use_sdk_api,avmedia,))
+
+$(eval $(call gb_Library_use_externals,avmedia,\
+ boost_headers \
+))
+
+ifeq ($(USE_AVMEDIA_DUMMY),TRUE)
+$(eval $(call gb_Library_add_exception_objects,avmedia,\
+ avmedia/source/avmediadummy \
+))
+
+
+else
+
+
+$(eval $(call gb_Library_add_defs,avmedia,\
+ -DAVMEDIA_DLLIMPLEMENTATION \
+))
+
+ifeq ($(DISABLE_GUI),)
+$(eval $(call gb_Library_use_externals,avmedia,\
+ epoxy \
+))
+endif
+
+
+$(eval $(call gb_Library_use_libraries,avmedia,\
+ comphelper \
+ ucbhelper \
+ cppu \
+ cppuhelper \
+ sal \
+ i18nlangtag \
+ sfx \
+ svl \
+ svt \
+ tl \
+ utl \
+ vcl \
+))
+
+$(eval $(call gb_Library_add_exception_objects,avmedia,\
+ avmedia/source/framework/mediacontrol \
+ avmedia/source/framework/MediaControlBase \
+ avmedia/source/framework/mediaitem \
+ avmedia/source/framework/mediaplayer \
+ avmedia/source/framework/mediatoolbox \
+ avmedia/source/framework/soundhandler \
+ avmedia/source/viewer/mediaevent_impl \
+ avmedia/source/viewer/mediawindow \
+ avmedia/source/viewer/mediawindow_impl \
+))
+endif
+
+# vim: set noet sw=4 ts=4: