summaryrefslogtreecommitdiffstats
path: root/basctl/Module_basctl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /basctl/Module_basctl.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'basctl/Module_basctl.mk')
-rw-r--r--basctl/Module_basctl.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/basctl/Module_basctl.mk b/basctl/Module_basctl.mk
new file mode 100644
index 000000000..304a81dc9
--- /dev/null
+++ b/basctl/Module_basctl.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Module_Module,basctl))
+
+ifneq ($(filter SCRIPTING,$(BUILD_TYPE)),)
+
+$(eval $(call gb_Module_add_targets,basctl,\
+ Library_basctl \
+ UIConfig_basicide \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,basctl,\
+ AllLangMoTarget_basctl \
+))
+
+endif
+
+# screenshots
+$(eval $(call gb_Module_add_screenshot_targets,basctl,\
+ CppunitTest_basctl_dialogs_test \
+))
+
+# vim: set noet sw=4 ts=4: