summaryrefslogtreecommitdiffstats
path: root/desktop/Executable_quickstart.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /desktop/Executable_quickstart.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/Executable_quickstart.mk')
-rw-r--r--desktop/Executable_quickstart.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/desktop/Executable_quickstart.mk b/desktop/Executable_quickstart.mk
new file mode 100644
index 000000000..f0df0bbe7
--- /dev/null
+++ b/desktop/Executable_quickstart.mk
@@ -0,0 +1,44 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,quickstart))
+
+$(eval $(call gb_Executable_set_targettype_gui,quickstart,YES))
+
+$(eval $(call gb_Executable_use_system_win32_libs,quickstart,\
+ comdlg32 \
+ gdi32 \
+ ole32 \
+ oleaut32 \
+ shell32 \
+))
+
+ifeq ($(COM),GCC)
+
+$(eval $(call gb_Executable_use_system_win32_libs,quickstart,\
+ uuid \
+))
+
+else
+
+$(eval $(call gb_Executable_use_system_win32_libs,quickstart,\
+ comsupp \
+))
+
+endif
+
+$(eval $(call gb_Executable_add_exception_objects,quickstart,\
+ desktop/win32/source/QuickStart/QuickStart \
+))
+
+$(eval $(call gb_Executable_add_nativeres,quickstart,quickstart/QuickStart))
+
+$(eval $(call gb_Executable_add_default_nativeres,quickstart))
+
+# vim: set ts=4 sw=4 et: