summaryrefslogtreecommitdiffstats
path: root/desktop/Library_offacc.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /desktop/Library_offacc.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/Library_offacc.mk')
-rw-r--r--desktop/Library_offacc.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/desktop/Library_offacc.mk b/desktop/Library_offacc.mk
new file mode 100644
index 000000000..b50dd4441
--- /dev/null
+++ b/desktop/Library_offacc.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,offacc))
+
+$(eval $(call gb_Library_use_sdk_api,offacc))
+
+$(eval $(call gb_Library_use_libraries,offacc,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+))
+
+$(eval $(call gb_Library_set_componentfile,offacc,desktop/source/offacc/offacc))
+
+$(eval $(call gb_Library_add_exception_objects,offacc,\
+ desktop/source/offacc/acceptor \
+))
+
+# vim: set ts=4 sw=4 et: