summaryrefslogtreecommitdiffstats
path: root/desktop/Library_spl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /desktop/Library_spl.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/Library_spl.mk')
-rw-r--r--desktop/Library_spl.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/desktop/Library_spl.mk b/desktop/Library_spl.mk
new file mode 100644
index 000000000..89c8e53b9
--- /dev/null
+++ b/desktop/Library_spl.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,spl))
+
+$(eval $(call gb_Library_set_include,spl,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/desktop/inc \
+))
+
+$(eval $(call gb_Library_use_external,spl,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,spl))
+
+$(eval $(call gb_Library_use_libraries,spl,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+ ucbhelper \
+ utl \
+ vcl \
+))
+
+$(eval $(call gb_Library_set_componentfile,spl,desktop/source/splash/spl))
+
+$(eval $(call gb_Library_add_exception_objects,spl,\
+ desktop/source/splash/services_spl \
+ desktop/source/splash/splash \
+ desktop/source/splash/unxsplash \
+))
+
+# vim: set ts=4 sw=4 et: