summaryrefslogtreecommitdiffstats
path: root/dtrans/Library_ftransl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /dtrans/Library_ftransl.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dtrans/Library_ftransl.mk')
-rw-r--r--dtrans/Library_ftransl.mk53
1 files changed, 53 insertions, 0 deletions
diff --git a/dtrans/Library_ftransl.mk b/dtrans/Library_ftransl.mk
new file mode 100644
index 000000000..5a16ee83c
--- /dev/null
+++ b/dtrans/Library_ftransl.mk
@@ -0,0 +1,53 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Library_Library,ftransl))
+
+$(eval $(call gb_Library_set_componentfile,ftransl,dtrans/util/ftransl))
+
+$(eval $(call gb_Library_use_sdk_api,ftransl))
+
+$(eval $(call gb_Library_use_libraries,ftransl,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+))
+
+$(eval $(call gb_Library_use_system_win32_libs,ftransl,\
+ advapi32 \
+ gdi32 \
+ ole32 \
+))
+
+$(eval $(call gb_Library_use_static_libraries,ftransl,\
+ dtobj \
+))
+
+$(eval $(call gb_Library_add_exception_objects,ftransl,\
+ dtrans/source/win32/ftransl/ftransl \
+ dtrans/source/win32/ftransl/ftranslentry \
+))
+
+$(eval $(call gb_Library_set_include,ftransl,\
+ -I$(SRCDIR)/dtrans/source/inc \
+ $$(INCLUDE) \
+))
+
+# vim: set noet sw=4 ts=4: