summaryrefslogtreecommitdiffstats
path: root/emfio/CppunitTest_emfio_wmf_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /emfio/CppunitTest_emfio_wmf_test.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'emfio/CppunitTest_emfio_wmf_test.mk')
-rw-r--r--emfio/CppunitTest_emfio_wmf_test.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/emfio/CppunitTest_emfio_wmf_test.mk b/emfio/CppunitTest_emfio_wmf_test.mk
new file mode 100644
index 000000000..ec67bff3a
--- /dev/null
+++ b/emfio/CppunitTest_emfio_wmf_test.mk
@@ -0,0 +1,48 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,emfio_wmf))
+
+$(eval $(call gb_CppunitTest_set_include,emfio_wmf,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/emfio/inc \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,emfio_wmf,\
+ boost_headers \
+ libxml2 \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,emfio_wmf, \
+ emfio/qa/cppunit/wmf/wmfimporttest \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,emfio_wmf,\
+ emfio \
+ sal \
+ test \
+ tl \
+ unotest \
+ vcl \
+))
+
+$(eval $(call gb_CppunitTest_use_components,emfio_wmf,\
+ configmgr/source/configmgr \
+ emfio/emfio \
+ i18npool/util/i18npool \
+ ucb/source/core/ucb1 \
+ unotools/util/utl \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,emfio_wmf))
+$(eval $(call gb_CppunitTest_use_sdk_api,emfio_wmf))
+$(eval $(call gb_CppunitTest_use_ure,emfio_wmf))
+$(eval $(call gb_CppunitTest_use_vcl,emfio_wmf))
+
+# vim: set noet sw=4 ts=4: