summaryrefslogtreecommitdiffstats
path: root/external/more_fonts/ExternalPackage_sourcecode.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /external/more_fonts/ExternalPackage_sourcecode.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'external/more_fonts/ExternalPackage_sourcecode.mk')
-rw-r--r--external/more_fonts/ExternalPackage_sourcecode.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/external/more_fonts/ExternalPackage_sourcecode.mk b/external/more_fonts/ExternalPackage_sourcecode.mk
new file mode 100644
index 000000000..5f1d7f7c5
--- /dev/null
+++ b/external/more_fonts/ExternalPackage_sourcecode.mk
@@ -0,0 +1,29 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_ExternalPackage_ExternalPackage,fonts_sourcecode,font_sourcecode))
+
+$(eval $(call gb_ExternalPackage_add_unpacked_files,fonts_sourcecode,$(LIBO_SHARE_FOLDER)/fonts/truetype,\
+ SourceCodePro-BlackIt.ttf \
+ SourceCodePro-Black.ttf \
+ SourceCodePro-BoldIt.ttf \
+ SourceCodePro-Bold.ttf \
+ SourceCodePro-ExtraLightIt.ttf \
+ SourceCodePro-ExtraLight.ttf \
+ SourceCodePro-It.ttf \
+ SourceCodePro-LightIt.ttf \
+ SourceCodePro-Light.ttf \
+ SourceCodePro-MediumIt.ttf \
+ SourceCodePro-Medium.ttf \
+ SourceCodePro-Regular.ttf \
+ SourceCodePro-SemiboldIt.ttf \
+ SourceCodePro-Semibold.ttf \
+))
+
+# vim: set noet sw=4 ts=4: