summaryrefslogtreecommitdiffstats
path: root/i18npool/Executable_gencoll_rule.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /i18npool/Executable_gencoll_rule.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'i18npool/Executable_gencoll_rule.mk')
-rw-r--r--i18npool/Executable_gencoll_rule.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/i18npool/Executable_gencoll_rule.mk b/i18npool/Executable_gencoll_rule.mk
new file mode 100644
index 000000000..06b05e9e1
--- /dev/null
+++ b/i18npool/Executable_gencoll_rule.mk
@@ -0,0 +1,32 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,gencoll_rule))
+
+$(eval $(call gb_Executable_set_include,gencoll_rule,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/i18npool/inc \
+))
+
+$(eval $(call gb_Executable_use_libraries,gencoll_rule,\
+ sal \
+))
+
+$(eval $(call gb_Executable_use_externals,gencoll_rule,\
+ icui18n \
+ icuuc \
+ $(if $(filter TRUE,$(DISABLE_DYNLOADING)),icudata) \
+ icu_headers \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,gencoll_rule,\
+ i18npool/source/collator/gencoll_rule \
+))
+
+# vim: set noet sw=4 ts=4: